summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVuiMuich2020-10-23 18:27:51 +0200
committerVuiMuich2020-10-23 18:27:51 +0200
commit372803d5c48c3f1496325601593558dcd4774685 (patch)
treeab7b52e5d9209863a7cacc0030df3c1b71cd1d15
parent89dc2a49c91f8dcbc2b517e28d7641e34309c82b (diff)
downloadaur-372803d5c48c3f1496325601593558dcd4774685.tar.gz
pushed to 0.4.1 and added installation of manpage
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 77f12c15255b..588d6a51c67a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: PinkCathodeCat <awils_1 atsymbol xsmail dot com>
# Contributor: Tbsc <me in tbscdev point xyz>
+# Contributor: VuiMuich <jm dot spam atsymbol gmx dot net>
pkgname=ratslap
-pkgver=0.4.0
-pkgrel=2
+pkgver=0.4.1
+pkgrel=0
pkgdesc="Community made Linux drivers for Logitech mice (Currently only G300s)"
arch=('i686' 'x86_64')
url="https://gitlab.com/krayon/$pkgname"
@@ -20,6 +21,8 @@ md5sums=('SKIP')
build() {
cd "$srcdir/$pkgname"
make
+ cp manpage.1 "$pkgname.1"
+ gzip "$pkgname.1"
}
check() {
@@ -29,4 +32,5 @@ check() {
package() {
cd "$srcdir/$pkgname"
install -Dm755 "$srcdir/$pkgname/$pkgname" "${pkgdir}/usr/bin/ratslap"
+ install -D -g 0 -o 0 -m 0644 "$srcdir/$pkgname/$pkgname.1.gz" "${pkgdir}/usr/share/man/man1/$pkgname.1.gz"
}