summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVirtualTam2016-03-25 19:59:59 +0100
committerVirtualTam2016-03-25 19:59:59 +0100
commitc59feb630aafd437ec574106bf647bba64170493 (patch)
tree13205bee294add22ce576502e5f0e4f4f0fd0af9
downloadaur-c59feb630aafd437ec574106bf647bba64170493.tar.gz
raul-git: initial PKGBUILD
Signed-off-by: VirtualTam <virtualtam@flibidi.net>
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b203751de68b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Mar 25 18:59:31 UTC 2016
+pkgbase = raul-git
+ pkgdesc = Realtime Audio Utility Library aimed at audio and musical applications
+ pkgver = 2901a1a
+ pkgrel = 1
+ url = http://drobilla.net/software/raul/
+ arch = any
+ license = GPL3
+ makedepends = boost
+ makedepends = git
+ makedepends = python
+ depends = glib2
+ provides = raul
+ conflicts = raul
+ source = git+http://git.drobilla.net/raul.git
+ sha256sums = SKIP
+
+pkgname = raul-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..092e8b325aa9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+raul
+pkg
+src
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6be061b4793
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: VirtualTam <virtualtam@flibidi.net>
+pkgname=raul-git
+pkgver=2901a1a
+pkgrel=1
+pkgdesc="Realtime Audio Utility Library aimed at audio and musical applications"
+arch=(any)
+url="http://drobilla.net/software/raul/"
+license=('GPL3')
+depends=('glib2')
+makedepends=('boost' 'git' 'python')
+provides=('raul')
+conflicts=('raul')
+_gitname="raul"
+source=(git+http://git.drobilla.net/${_gitname}.git)
+sha256sums=(SKIP)
+
+pkgver() {
+ cd ${_gitname}
+ git describe --long --tags --always | sed 's/^release.//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build(){
+ cd ${_gitname}
+ python waf configure --prefix="/usr"
+ python waf build ${MAKEFLAGS}
+}
+
+package() {
+ cd ${_gitname}
+ python waf install --destdir=${pkgdir}
+}