summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12018-02-25 14:34:31 +0800
committerChocobo12018-02-25 15:29:14 +0800
commit8614fc8b3cb2d3a91d922ea77411281371bbd483 (patch)
tree2ff975daa097b895ed3b3933351150833e7e72f1
downloadaur-8614fc8b3cb2d3a91d922ea77411281371bbd483.tar.gz
newpkg: rav1e-git r176.f2df716-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD53
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..272b05032e0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = rav1e-git
+ pkgdesc = The fastest and safest AV1 encoder
+ pkgver = r176.f2df716
+ pkgrel = 1
+ url = https://github.com/xiph/rav1e
+ arch = i686
+ arch = x86_64
+ license = custom
+ license = BSD
+ makedepends = git
+ makedepends = cargo
+ depends = gcc-libs
+ provides = rav1e
+ conflicts = rav1e
+ options = staticlibs
+ source = git+https://github.com/xiph/rav1e.git
+ sha256sums = SKIP
+
+pkgname = rav1e-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ba759781da6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=rav1e-git
+pkgver=r176.f2df716
+pkgrel=1
+pkgdesc="The fastest and safest AV1 encoder"
+arch=('i686' 'x86_64')
+url="https://github.com/xiph/rav1e"
+license=('custom' 'BSD')
+depends=('gcc-libs')
+makedepends=('git' 'cargo')
+provides=('rav1e')
+conflicts=('rav1e')
+options=('staticlibs')
+source=("git+https://github.com/xiph/rav1e.git")
+sha256sums=('SKIP')
+
+
+prepare() {
+ cd "rav1e"
+
+ git submodule update --init --depth 1
+}
+
+pkgver() {
+ cd "rav1e"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "rav1e"
+
+ cargo build --release
+}
+
+check() {
+ cd "rav1e"
+
+ cargo test --release
+}
+
+package() {
+ cd "rav1e"
+
+ install -Dm755 "target/release/rav1e" "$pkgdir/usr/bin/rav1e"
+ install -Dm755 "target/release/rav1repl" "$pkgdir/usr/bin/rav1repl"
+
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/rav1e/README.md"
+
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/rav1e/LICENSE"
+ install -Dm644 "PATENTS" "$pkgdir/usr/share/licenses/rav1e/PATENTS"
+}