summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMako882015-06-11 09:26:48 -0500
committerMako882015-06-11 09:26:48 -0500
commit7a4de124d3b0887c7c2eb5752713c72ba551961a (patch)
tree3c23c4754b9f1f6861475728dd63c4afaeb302f6
downloadaur-7a4de124d3b0887c7c2eb5752713c72ba551961a.tar.gz
Initial Commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD19
-rw-r--r--update-icon-cache.install14
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f28e2eb54ab2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = rave-x-colors
+ pkgdesc = A vivid and classically styled icon theme based on Faenza. The inspiration for Mint-X, but with support for dark panels.
+ pkgver = 2.0B
+ pkgrel = 1
+ url = http://www.ravefinity.com/p/rave-x-icon-theme.html
+ install = update-icon-cache.install
+ arch = any
+ groups = x11
+ license = custom:cc-by-sa-3.0
+ license = GPL2
+ options = !strip
+ options = !zipman
+ options = libtool
+ options = staticlibs
+ source = rave-x-colors-2.0B.tar.gz::https://googledrive.com/host/0B7iDWdwgu9QAeGFIaVN6R21Qcjg
+ md5sums = 003193c3b119dbd7020cef9d5c0cebee
+
+pkgname = rave-x-colors
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d5a7bedcb72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: ThePilot <afuturepilotis at gmail dot com>
+pkgname=rave-x-colors
+pkgver=2.0B
+pkgrel=1
+pkgdesc="A vivid and classically styled icon theme based on Faenza. The inspiration for Mint-X, but with support for dark panels."
+arch=('any')
+url="http://www.ravefinity.com/p/rave-x-icon-theme.html"
+license=('custom:cc-by-sa-3.0' 'GPL2')
+groups=('x11')
+options=('!strip' '!zipman' 'libtool' 'staticlibs')
+install=update-icon-cache.install
+source=($pkgname-$pkgver.tar.gz::https://googledrive.com/host/0B7iDWdwgu9QARkRNbkl4NHhDZGs)
+md5sums=('003193c3b119dbd7020cef9d5c0cebee')
+
+package() {
+ mkdir -p $pkgdir/usr/share/icons/
+ cp -r $srcdir/* $pkgdir/usr/share/icons/
+ rm "$pkgdir/usr/share/icons/RAVEX-Icon-Manual-Doc.txt" "$pkgdir/usr/share/icons/rave-x-colors-2.0B.tar.gz"
+}
diff --git a/update-icon-cache.install b/update-icon-cache.install
new file mode 100644
index 000000000000..461e540338dc
--- /dev/null
+++ b/update-icon-cache.install
@@ -0,0 +1,14 @@
+post_install() {
+ for dir in usr/share/icons/RAVE*; do
+ gtk-update-icon-cache -ftq $dir
+ done
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+