summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchilleas Pipinellis2015-08-17 10:36:30 +0300
committerAchilleas Pipinellis2015-08-17 10:36:30 +0300
commit03cf639d21461e4e46cb06a02dcef109c954ce6a (patch)
tree0995f1c859ea9b253712ab427a38287846169d55
downloadaur-03cf639d21461e4e46cb06a02dcef109c954ce6a.tar.gz
Init commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5d36bd34821
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-pypcap
+ pkgdesc = A simplified object-oriented Python wrapper for libpcap
+ pkgver = 1.1.3
+ pkgrel = 1
+ url = https://github.com/pynetwork/pypcap
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ depends = python2
+ source = https://github.com/pynetwork/pypcap/archive/v1.1.3.zip
+ md5sums = 2bb733983f96509401d23590b9ae745d
+
+pkgname = python2-pypcap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..913510fb1671
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Achilleas Pipinellis <axilleas archlinux info>
+# Note: This is a fork fixing numerous bugs. You will not find this version
+# in pypi.
+
+pkgname=python2-pypcap
+_pkgname=pypcap
+pkgver=1.1.3
+pkgrel=1
+pkgdesc="A simplified object-oriented Python wrapper for libpcap"
+arch=(any)
+url="https://github.com/pynetwork/pypcap"
+license=('BSD')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=(https://github.com/pynetwork/$_pkgname/archive/v${pkgver}.zip)
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('2bb733983f96509401d23590b9ae745d')