summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChad Harp2015-11-10 12:48:15 -0600
committerChad Harp2015-11-10 12:48:15 -0600
commit4cb0d48821ce8fffe0813c3cc2c2588178389072 (patch)
treecd3a3615569a5d7c198fd8e1d7e0166e191e4236
parent29d4448490159e09904538eaea60cf86d4543663 (diff)
downloadaur-4cb0d48821ce8fffe0813c3cc2c2588178389072.tar.gz
Add additional dependencies and allow mimerender > 0.3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
-rw-r--r--ravello.patch12
3 files changed, 38 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 873dcc3e11d7..75eb6bd24743 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,24 @@
pkgbase = ravello
pkgdesc = ravello systems tool
pkgver = 2.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.ravellosystems.com/
arch = any
license = Unknown
makedepends = python2-setuptools
depends = python2
depends = python2-pysphere
+ depends = python2-requests
+ depends = python2-pefile-git
+ depends = python2-argparse
+ depends = python2-jsonpickle
+ depends = python2-webpy
+ depends = python2-mimerender
+ depends = python2-boto
source = http://import-tool.ravellosystems.com/linux/ravello_linux.tar.gz
- sha512sums = 713bf014178f70c00570eddf2a58abac4ad6d7217ae2e882742e872a9007c01952b2f70a172a3bcee55fbb66f79f13b682868b4f4567fc06f5124d61599bd317
+ source = ravello.patch
+ sha512sums = 14f76391aa2ee7d147430b9885cc759eacb7cffb52539ea503f8f26c962c0c2d81afac8168bf32921449841befbf655e1a7f3989cf814c748a2403c4061d8cfd
+ sha512sums = 6e8c4ba79bc7c9b595e53068528cac7ed76f45f6c4e1292cd88b468c5e113580da401f70d756dd3dae475dbc89acddffb6b4e329fc2b2b212b72fce6afc53ad5
pkgname = ravello
diff --git a/PKGBUILD b/PKGBUILD
index 6661160b3885..762dc8185c66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,19 @@
pkgname="ravello"
pkgver=2.0
-pkgrel=1
+pkgrel=2
pkgdesc="ravello systems tool"
url="https://www.ravellosystems.com/"
license=('Unknown')
-source=("http://import-tool.ravellosystems.com/linux/ravello_linux.tar.gz")
-sha512sums=('713bf014178f70c00570eddf2a58abac4ad6d7217ae2e882742e872a9007c01952b2f70a172a3bcee55fbb66f79f13b682868b4f4567fc06f5124d61599bd317')
+source=("http://import-tool.ravellosystems.com/linux/ravello_linux.tar.gz"
+ "ravello.patch")
+sha512sums=('14f76391aa2ee7d147430b9885cc759eacb7cffb52539ea503f8f26c962c0c2d81afac8168bf32921449841befbf655e1a7f3989cf814c748a2403c4061d8cfd'
+ '6e8c4ba79bc7c9b595e53068528cac7ed76f45f6c4e1292cd88b468c5e113580da401f70d756dd3dae475dbc89acddffb6b4e329fc2b2b212b72fce6afc53ad5')
arch=('any')
-depends=('python2' 'python2-pysphere')
+depends=('python2' 'python2-pysphere' 'python2-requests' 'python2-pefile-git'
+'python2-argparse' 'python2-jsonpickle' 'python2-webpy' 'python2-mimerender'
+'python2-boto')
+
makedepends=('python2-setuptools')
conflicts=("${_gitname}")
provides=("${_gitname}")
@@ -24,9 +29,14 @@ pkgver() {
)
}
+prepare() {
+ cd "${srcdir}"
+ patch -Np0 -i "$srcdir/ravello.patch"
+}
+
package() {
cd "${srcdir}/${pkgname}/${pkgname}-${pkgver}"
python2 setup.py install --root="$pkgdir/" --optimize=1
}
-# vim:set et sw=2 sts=2 tw=80: \ No newline at end of file
+# vim:set et sw=2 sts=2 tw=80:
diff --git a/ravello.patch b/ravello.patch
new file mode 100644
index 000000000000..10c259bd7747
--- /dev/null
+++ b/ravello.patch
@@ -0,0 +1,12 @@
+diff -ur ravello/ravello-2.0/setup.py ravello.o/ravello-2.0/setup.py
+--- ravello/ravello-2.0/setup.py 2015-11-10 11:04:51.740511280 -0600
++++ ravello.o/ravello-2.0/setup.py 2015-11-10 11:03:47.887431323 -0600
+@@ -36,7 +36,7 @@
+ 'ravello = ravello.cli.ravello_cli:run',
+ 'ravello_vm_import_server = ravello.imageloader.server.ravello_vm_import_server:main']},
+ # other arguments here...
++ install_requires=['boto >=2.8', 'mimerender >=0.3', 'web.py', 'httplib2', 'jsonpickle', 'argparse', 'pefile','requests', 'pysphere']
+- install_requires=['boto >=2.8', 'mimerender ==0.3', 'web.py', 'httplib2', 'jsonpickle', 'argparse', 'pefile','requests', 'pysphere']
+ )
+
+ if os.path.exists(dst_static_path):