summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukáš Jirkovský2015-08-30 12:59:37 +0200
committerLukáš Jirkovský2015-08-30 12:59:37 +0200
commit8dc6bd1431e4fa9c81e702af30c6882c52afd97f (patch)
treec244d20e285187aa751d3744f82946d0001804aa
downloadaur-8dc6bd1431e4fa9c81e702af30c6882c52afd97f.tar.gz
initial import after switch to git
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD34
-rw-r--r--rawtherapee.install17
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25f4e7b43ca1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = rawtherapee-git
+ pkgdesc = RAW photo editor
+ pkgver = 2971.11d382d
+ pkgrel = 1
+ url = http://www.rawtherapee.com/
+ install = rawtherapee.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ depends = fftw
+ depends = gtkmm
+ depends = libcanberra
+ depends = libiptcdata
+ depends = lcms2
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ provides = rawtherapee
+ conflicts = rawtherapee
+ source = rawtherapee::git+https://github.com/Beep6581/RawTherapee.git
+ md5sums = SKIP
+
+pkgname = rawtherapee-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3be0fde31484
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Lukas Jirkovsky <l.jirkovsky AT gmail.com>
+pkgname=rawtherapee-git
+pkgver=2971.11d382d
+pkgrel=1
+pkgdesc="RAW photo editor"
+arch=('i686' 'x86_64')
+url="http://www.rawtherapee.com/"
+license=('GPL3')
+depends=('fftw' 'gtkmm' 'libcanberra' 'libiptcdata' 'lcms2' 'desktop-file-utils' 'hicolor-icon-theme')
+makedepends=('cmake' 'git')
+provides=('rawtherapee')
+conflicts=('rawtherapee')
+install=rawtherapee.install
+source=('rawtherapee::git+https://github.com/Beep6581/RawTherapee.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/rawtherapee"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/rawtherapee"
+
+ cmake . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd "$srcdir/rawtherapee"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/rawtherapee.install b/rawtherapee.install
new file mode 100644
index 000000000000..6a18adf6ea24
--- /dev/null
+++ b/rawtherapee.install
@@ -0,0 +1,17 @@
+post_install() {
+ echo "update desktop mime database..."
+ update-desktop-database -q
+ update-mime-database usr/share/mime 1>&2 > /dev/null
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+
+# vim:set ts=2 sw=2 et: