summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormalacology2021-04-29 12:34:50 +0800
committermalacology2021-04-29 12:34:50 +0800
commit2276ebf30fcac0f0132ecc43c148c30b278d8455 (patch)
tree89452c531aa7060df20a9018c984fa72bb5b7c05
parent9934f63fe3591acea761f46a9898bb6701d33297 (diff)
downloadaur-2276ebf30fcac0f0132ecc43c148c30b278d8455.tar.gz
MPI version
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD44
2 files changed, 10 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b6ac1d501d4..de66e8aeaacb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,7 +13,7 @@ pkgbase = raxml-ng
makedepends = git
makedepends = gmp
depends = gcc-libs
- source = git+https://github.com/amkozlov/raxml-ng.git#commit=411611611793e53c992717d869ca64370f2e4789
+ source = https://github.com/amkozlov/raxml-ng/releases/1.0.2/raxml-ng_v1.0.2_linux_x86_64_MPI.zip
sha256sums = SKIP
pkgname = raxml-ng
diff --git a/PKGBUILD b/PKGBUILD
index 02c115773a01..f3fddd22699b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,27 @@
-# Maintainer: Roberto Rossini ("robymetallo") <roberros@insert_university_of_oslo_domain.no>
+# Maintainer: Guoyi ("malcology") <guoyizhang@malacology.net>
+# Contributor: Guoyi ("malcology") <guoyizhang@malacology.net>
+# Contributor: Roberto Rossini ("robymetallo") <roberros@insert_university_of_oslo_domain.no>
pkgname=raxml-ng
pkgver=1.0.2
_commit=411611611793e53c992717d869ca64370f2e4789
pkgrel=1
-pkgdesc="A phylogenetic tree inference tool which uses maximum-likelihood (ML)\
- optimality criterion"
-
+pkgdesc="A phylogenetic tree inference tool which uses maximum-likelihood (ML) optimality criterion"
url='https://github.com/amkozlov/raxml-ng'
arch=('x86_64')
-
license=('AGPL3')
-
depends=('gcc-libs')
-
makedepends=('bison' 'cmake' 'flex' 'git' 'gmp')
-
checkdepends=('gmock' 'gtest')
-
-source=("git+https://github.com/amkozlov/$pkgname.git#commit=$_commit")
-
+source=("https://github.com/amkozlov/raxml-ng/releases/${pkgver}/raxml-ng_v${pkgver}_linux_x86_64_MPI.zip")
sha256sums=('SKIP')
prepare() {
- cd $pkgname
-
- git submodule update --init --recursive
-
- mkdir build/
- cd build/
-
- cmake ..
-}
-
-build() {
- cd $pkgname/build
-
- make
-}
-
-check() {
- cd $pkgname/build
- make test
-
- #./$pkgname -v | grep -Pxq "RAxML-NG v\. 1\.0\.2 released on \d+\.\d+\.\d+ by The Exelixis Lab\."
+ cd "${srcdir}"
}
package() {
- cd $pkgname
-
- install -Dm755 bin/$pkgname "$pkgdir/usr/bin/$pkgname"
+ cd "${srcdir}"
+ ./install.sh
+ install -Dm755 "${srcdir}/bin/raxml-ng-mpi" "${pkgdir}/usr/bin/${pkgname}"
}