summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Rossini2019-09-27 21:43:39 +0200
committerRoberto Rossini2019-09-27 21:43:39 +0200
commit7d1f3d543df7fb6de6414cbac6ff3870076f598b (patch)
treee942de276d364e5860c6634c624e01859022c07d
downloadaur-7d1f3d543df7fb6de6414cbac6ff3870076f598b.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD52
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..91c0575115b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = raxml-ng
+ pkgdesc = A phylogenetic tree inference tool which uses maximum-likelihood (ML) optimality criterion
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://github.com/amkozlov/raxml-ng
+ arch = x86_64
+ license = AGPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = bison
+ makedepends = flex
+ makedepends = gmp
+ depends = gcc-libs
+ source = git+https://github.com/amkozlov/raxml-ng.git#commit=0a064e9a40f2e00828662795141659d946440c81
+ sha256sums = SKIP
+
+pkgname = raxml-ng
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..868b478b3469
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Roberto Rossini ("robymetallo") <roberto.rossini.9533@student.uu.se>
+
+pkgname=raxml-ng
+pkgver=0.9.0
+_release=0a064e9a40f2e00828662795141659d946440c81
+pkgrel=1
+pkgdesc="A phylogenetic tree inference tool which uses maximum-likelihood (ML)\
+ optimality criterion"
+
+url='https://github.com/amkozlov/raxml-ng'
+arch=('x86_64')
+
+license=('AGPL3')
+
+depends=('gcc-libs')
+
+makedepends=('git' 'cmake' 'bison' 'flex' 'gmp')
+
+source=("git+https://github.com/amkozlov/$pkgname.git#commit=$_release")
+
+# source=("https://github.com/amkozlov/$pkgname/archive/$pkgver.tar.gz")
+# sha256sums=('43b95ee1bddae0daee84644e9ee760a77f28bb16e2071e95cca79a30f39373e5')
+sha256sums=('SKIP')
+
+prepare() {
+ cd $pkgname
+
+ git submodule update --init --recursive
+
+ mkdir build/
+ cd build/
+
+ cmake ..
+}
+
+build() {
+ cd $pkgname/build
+
+ make
+}
+
+check() {
+ cd $pkgname/bin
+
+ ./$pkgname -v | grep -Pxq "RAxML-NG v\. 0\.9\.0 released on \d+\.\d+\.\d+ by The Exelixis Lab\."
+}
+
+package() {
+ cd $pkgname
+
+ install -Dm755 bin/$pkgname "$pkgdir/usr/bin/$pkgname"
+}