summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKuoi2022-08-28 23:09:48 +0100
committerKuoi2022-08-28 23:09:48 +0100
commitdcd3763ed5f4fe11ead59f41c4d863bec11da7f2 (patch)
tree7221a2fe529f5ab0cf7ec997ea2faf84fb5a68b8
downloadaur-dcd3763ed5f4fe11ead59f41c4d863bec11da7f2.tar.gz
init
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD31
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3170d2e93b13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = raxml-ng-mpi
+ pkgdesc = A phylogenetic tree inference tool which uses maximum-likelihood (ML) optimality criterion. https://doi.org/10.1093/bioinformatics/btz305
+ pkgver = 1.1.0
+ pkgrel = 18
+ url = https://github.com/amkozlov/raxml-ng
+ arch = x86_64
+ license = AGPL3
+ makedepends = bison
+ makedepends = make
+ makedepends = cmake
+ makedepends = flex
+ makedepends = gmp
+ makedepends = gtest
+ makedepends = git
+ depends = gcc-libs
+ depends = openmpi
+ depends = cuda
+ provides = raxml-ng
+ conflicts = raxml-ng
+ source = git+https://github.com/amkozlov/raxml-ng.git#tag=1.1.0
+ sha256sums = SKIP
+
+pkgname = raxml-ng-mpi
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a01a79db501e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Guoyi ("malcology") <guoyizhang@malacology.net>
+# Contributor: Guoyi ("malcology") <guoyizhang@malacology.net>
+
+pkgname=raxml-ng-mpi
+pkgver=1.1.0
+pkgrel=18
+pkgdesc="A phylogenetic tree inference tool which uses maximum-likelihood (ML) optimality criterion. https://doi.org/10.1093/bioinformatics/btz305"
+url='https://github.com/amkozlov/raxml-ng'
+arch=('x86_64')
+license=('AGPL3')
+depends=('gcc-libs' 'openmpi' 'cuda')
+makedepends=('bison' 'make' 'cmake' 'flex' 'gmp' 'gtest' 'git')
+source=("git+https://github.com/amkozlov/raxml-ng.git#tag=${pkgver}")
+sha256sums=('SKIP')
+provides=('raxml-ng')
+conflicts=('raxml-ng')
+prepare(){
+ cd ${srcdir}/raxml-ng
+ git submodule update --init --recursive
+}
+build(){
+ cd "${srcdir}"/raxml-ng
+ mkdir -p build
+ cd build
+ cmake -DUSE_MPI=ON ..
+ make
+}
+package() {
+ cd ${srcdir}/raxml-ng/bin
+ install -Dm755 $pkgname "${pkgdir}/usr/bin/${pkgname}"
+}