summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Pina Martins2015-06-09 14:12:20 +0100
committerFrancisco Pina Martins2015-06-09 14:12:20 +0100
commit863f9737d0aa06d82e7139ced1bc93262f288953 (patch)
treec7ba4aabee8cfb061e9e67d54ffb487c7faeae46
downloadaur-863f9737d0aa06d82e7139ced1bc93262f288953.tar.gz
Initial import.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD79
2 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05a471474f1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = raxml-standard-git
+ pkgdesc = Randomized Axelerated Maximum Likelihood - standard version from git
+ pkgver = 20150208
+ pkgrel = 1
+ url = https://github.com/stamatak/standard-RAxML
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = make
+ optdepends = openmpi: for buildin MPI capable binary
+ conflicts = raxml
+ conflicts = raxml-mpi
+ source = git+git://github.com/stamatak/standard-RAxML.git
+ md5sums = SKIP
+
+pkgname = raxml-standard-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e12992df85d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,79 @@
+# Contributor: Stunts <f.pinamartins@gmail.com>
+pkgname=raxml-standard-git
+pkgver=20150208
+pkgrel=1
+pkgdesc="Randomized Axelerated Maximum Likelihood - standard version from git"
+arch=(i686 x86_64)
+url="https://github.com/stamatak/standard-RAxML"
+license=('GPL3')
+
+depends=()
+optdepends=('openmpi: for buildin MPI capable binary')
+makedepends=('git' 'make')
+conflicts=('raxml' 'raxml-mpi')
+source=('git+git://github.com/stamatak/standard-RAxML.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/standard-RAxML
+ git log -1 --format='%cd' --date=short | tr -d -- '-'
+}
+
+prepare() {
+#Check whether the CPU supports SSE3 instruction set:
+ if $(grep -q pni /proc/cpuinfo)
+ then
+ makefile=Makefile.SSE3
+ extension=-SSE3
+ msg "Using SSE3 instruction set since your CPU seems to support it."
+ else
+ makefile=Makefile
+ extension=''
+ msg "Not using SSE3 instructions set since your CPU does not seem to support it."
+ fi
+}
+
+build() {
+ cd ${srcdir}/standard-RAxML
+
+ #Build single thread binary
+ msg "Building single thread binary..."
+ make -f ${makefile}.gcc
+ rm *.o
+
+ #Build MPI binary (if OpenMPI is available)
+ msg "Looking for mpicc..."
+ if $(which mpicc |grep -q "/")
+ then
+ msg "Found a suitable mpicc, building MPI binary..."
+ make -f ${makefile}.MPI.gcc
+ rm *.o
+ mpi=1
+ else
+ msg "No suitable mpicc found, skipping MPI binary build."
+ mpi=0
+ fi
+
+ #Build Pthreads binary
+ msg "Building PTHREADS binary..."
+ make -f ${makefile}.PTHREADS.gcc
+ rm *.o
+}
+
+package() {
+
+ if $(grep -q pni /proc/cpuinfo)
+ then
+ extension=-SSE3
+ else
+ extension=''
+ fi
+
+ install -d ${pkgdir}/usr/bin
+ cp ${srcdir}/standard-RAxML/raxmlHPC${extension} ${pkgdir}/usr/bin/
+ cp ${srcdir}/standard-RAxML/raxmlHPC-PTHREADS${extension} ${pkgdir}/usr/bin/
+ if [ $mpi ]
+ then
+ cp ${srcdir}/standard-RAxML/raxmlHPC-MPI${extension} ${pkgdir}/usr/bin/
+ fi
+}