summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2021-01-30 15:44:05 +0100
committerJan Cholasta2021-01-30 15:44:05 +0100
commit537ea761dd18675e383f31c6c11d2a8ac2e278cd (patch)
tree954294ce7c91df09677258dafa6fc998e3f5d5d4
parent0861d2498f64de1a1da1846ae286c6d622e194a2 (diff)
parent4499cf7e9ea39618ddce2e6c9f8687092035df74 (diff)
downloadaur-537ea761dd18675e383f31c6c11d2a8ac2e278cd.tar.gz
raze-0.8.1_beta-1
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Fix-file-paths.patch21
-rw-r--r--PKGBUILD6
3 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08b7b5652ae4..882793176ec6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = raze
pkgdesc = Build engine port backed by GZDoom tech
- pkgver = 0.7.3_alpha
+ pkgver = 0.8.1_beta
pkgrel = 1
url = https://github.com/coelckers/Raze
arch = x86_64
@@ -20,11 +20,11 @@ pkgbase = raze
optdepends = gxmessage: crash dialog (GNOME)
optdepends = kdialog: crash dialog (KDE)
optdepends = xorg-xmessage: crash dialog (other)
- source = Raze::git+https://github.com/coelckers/Raze#tag=0.7.3_alpha
+ source = Raze::git+https://github.com/coelckers/Raze#tag=0.8.1_beta
source = 0001-Fix-file-paths.patch
source = raze.desktop
sha256sums = SKIP
- sha256sums = 97891d1e02d9d159762af51011d57127960adac6d5b4cd16bba8e3863455d5f2
+ sha256sums = 5655c8685ebebf8ac7491dda3b4c8efd3b06f979111315df3fd87674dacfa963
sha256sums = ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8
pkgname = raze
diff --git a/0001-Fix-file-paths.patch b/0001-Fix-file-paths.patch
index cb00e3c5c96b..d862910407a1 100644
--- a/0001-Fix-file-paths.patch
+++ b/0001-Fix-file-paths.patch
@@ -1,13 +1,13 @@
-From ab0451141d00d316c98134ab07948942e6357ce8 Mon Sep 17 00:00:00 2001
+From 59d406377474990b43356132a7157eb23ccdcef4 Mon Sep 17 00:00:00 2001
From: Jan Cholasta <jan@cholasta.net>
Date: Thu, 6 Feb 2020 07:59:18 +0100
Subject: [PATCH] Fix file paths
---
source/common/platform/posix/sdl/i_main.cpp | 14 +-------------
- source/core/gameconfigfile.cpp | 13 +------------
+ source/core/gameconfigfile.cpp | 15 ++-------------
source/core/gamecontrol.cpp | 2 +-
- 3 files changed, 3 insertions(+), 26 deletions(-)
+ 3 files changed, 4 insertions(+), 27 deletions(-)
diff --git a/source/common/platform/posix/sdl/i_main.cpp b/source/common/platform/posix/sdl/i_main.cpp
index a984721fc..ddc209e34 100644
@@ -35,7 +35,7 @@ index a984721fc..ddc209e34 100644
I_StartupJoysticks();
diff --git a/source/core/gameconfigfile.cpp b/source/core/gameconfigfile.cpp
-index 115c737be..6e8d2f352 100644
+index 115c737be..c83ce70ed 100644
--- a/source/core/gameconfigfile.cpp
+++ b/source/core/gameconfigfile.cpp
@@ -100,15 +100,10 @@ FGameConfigFile::FGameConfigFile ()
@@ -54,9 +54,12 @@ index 115c737be..6e8d2f352 100644
#endif
SetValueForKey ("Path", "$STEAM", true); // also covers GOG.
-@@ -130,11 +125,8 @@ FGameConfigFile::FGameConfigFile ()
+@@ -128,13 +123,10 @@ FGameConfigFile::FGameConfigFile ()
+ SetValueForKey ("Path", "$GAMEDIR", true);
+ #else
SetValueForKey ("Path", "$HOME/" GAME_DIR, true);
- SetValueForKey ("Path", SHARE_DIR, true);
+- SetValueForKey ("Path", SHARE_DIR, true);
++ SetValueForKey ("Path", "/usr/share/raze", true);
SetValueForKey ("Path", "/usr/share/games/jfduke3d", true);
- SetValueForKey ("Path", "/usr/local/share/games/jfduke3d", true);
SetValueForKey ("Path", "/usr/share/games/eduke32", true);
@@ -79,10 +82,10 @@ index 115c737be..6e8d2f352 100644
}
diff --git a/source/core/gamecontrol.cpp b/source/core/gamecontrol.cpp
-index ef7d7a427..ae170eb19 100644
+index c034ff152..1ba99a14b 100644
--- a/source/core/gamecontrol.cpp
+++ b/source/core/gamecontrol.cpp
-@@ -776,7 +776,7 @@ int RunGame()
+@@ -823,7 +823,7 @@ int RunGame()
FString logfile = Args->TakeValue("+logfile");
// As long as this engine is still in prerelease mode let's always write a log file.
@@ -92,5 +95,5 @@ index ef7d7a427..ae170eb19 100644
if (logfile.IsNotEmpty())
{
--
-2.28.0
+2.30.0
diff --git a/PKGBUILD b/PKGBUILD
index 61c82fce88cb..6113262c3000 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
pkgname=raze
-pkgver=0.7.3_alpha
+pkgver=0.8.1_beta
pkgrel=1
pkgdesc='Build engine port backed by GZDoom tech'
arch=('x86_64')
@@ -25,7 +25,7 @@ source=("Raze::git+https://github.com/coelckers/Raze#tag=${pkgver}"
'0001-Fix-file-paths.patch'
'raze.desktop')
sha256sums=('SKIP'
- '97891d1e02d9d159762af51011d57127960adac6d5b4cd16bba8e3863455d5f2'
+ '5655c8685ebebf8ac7491dda3b4c8efd3b06f979111315df3fd87674dacfa963'
'ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8')
prepare() {
@@ -38,7 +38,7 @@ build() {
mkdir -p build
cmake -B build \
-D CMAKE_BUILD_TYPE=Release \
- -D CMAKE_CXX_FLAGS="${CXXFLAGS} -ffile-prefix-map=\"$PWD\"=. -DSHARE_DIR=\\\"/usr/share/raze\\\"" \
+ -D CMAKE_CXX_FLAGS="${CXXFLAGS} -ffile-prefix-map=\"$PWD\"=." \
-D DYN_GTK=OFF \
-D DYN_OPENAL=OFF
make -C build