summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2020-09-23 07:41:33 +0200
committerJan Cholasta2020-09-23 07:41:54 +0200
commitd5e1d2361485922174ffc6eb3cec6e0c557440df (patch)
treec95c34716a13772969223a68b11c60bb585325ac
parentffcfaace2011f296685b57c7426fefc703f61e32 (diff)
parent2ba53de3cd80a43e5dc0d160087dbfb8ca919aec (diff)
downloadaur-d5e1d2361485922174ffc6eb3cec6e0c557440df.tar.gz
raze-0.6.0-3
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fix-file-paths.patch26
-rw-r--r--PKGBUILD4
3 files changed, 9 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be5845b40f23..177464678170 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = raze
pkgdesc = Build engine port backed by GZDoom tech
pkgver = 0.6.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/coelckers/Raze
arch = x86_64
license = custom:BUILD
@@ -24,7 +24,7 @@ pkgbase = raze
source = 0001-Fix-file-paths.patch
source = raze.desktop
sha256sums = SKIP
- sha256sums = cb6a0ff91f3746a1bd9583540f51e3c3ad445a34b1a2a0a46d18a64797223e68
+ sha256sums = 09502741573bba7f8f8f91b74ecf88dd82d030ed0b185e72dee1cff51a17ec92
sha256sums = ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8
pkgname = raze
diff --git a/0001-Fix-file-paths.patch b/0001-Fix-file-paths.patch
index 04d35292b297..9eb97341adcf 100644
--- a/0001-Fix-file-paths.patch
+++ b/0001-Fix-file-paths.patch
@@ -1,4 +1,4 @@
-From 104b0ed4916d639c53cdb2d5e9caf3549330c113 Mon Sep 17 00:00:00 2001
+From 31a32f5be1739d5c9bd1c25ebe2b582ce9aa2fe6 Mon Sep 17 00:00:00 2001
From: Jan Cholasta <jan@cholasta.net>
Date: Thu, 6 Feb 2020 07:59:18 +0100
Subject: [PATCH] Fix file paths
@@ -6,9 +6,8 @@ Subject: [PATCH] Fix file paths
---
source/common/gameconfigfile.cpp | 13 +------------
source/common/gamecontrol.cpp | 2 +-
- source/common/music/i_soundfont.cpp | 4 +---
source/platform/posix/sdl/i_main.cpp | 14 +-------------
- 4 files changed, 4 insertions(+), 29 deletions(-)
+ 3 files changed, 3 insertions(+), 26 deletions(-)
diff --git a/source/common/gameconfigfile.cpp b/source/common/gameconfigfile.cpp
index dd4c0889e..ae7d282d4 100644
@@ -55,10 +54,10 @@ index dd4c0889e..ae7d282d4 100644
}
diff --git a/source/common/gamecontrol.cpp b/source/common/gamecontrol.cpp
-index 05ed78781..4b330ddff 100644
+index 99bc5ae6d..92e07fd6e 100644
--- a/source/common/gamecontrol.cpp
+++ b/source/common/gamecontrol.cpp
-@@ -599,7 +599,7 @@ int RunGame()
+@@ -613,7 +613,7 @@ int RunGame()
FString logfile = Args->TakeValue("+logfile");
// As long as this engine is still in prerelease mode let's always write a log file.
@@ -67,21 +66,6 @@ index 05ed78781..4b330ddff 100644
if (logfile.IsNotEmpty())
{
-diff --git a/source/common/music/i_soundfont.cpp b/source/common/music/i_soundfont.cpp
-index 672ec9268..046c52b7b 100644
---- a/source/common/music/i_soundfont.cpp
-+++ b/source/common/music/i_soundfont.cpp
-@@ -230,9 +230,7 @@ FPatchSetReader::FPatchSetReader(const char *filename)
- #ifndef _WIN32
- mCaseSensitivePaths = true;
- const char *paths[] = {
-- "/usr/local/lib/timidity",
-- "/etc/timidity",
-- "/etc"
-+ "/etc/timidity++"
- };
- #else
- const char *paths[] = {
diff --git a/source/platform/posix/sdl/i_main.cpp b/source/platform/posix/sdl/i_main.cpp
index b0e2ce978..0c2a2a96e 100644
--- a/source/platform/posix/sdl/i_main.cpp
@@ -108,5 +92,5 @@ index b0e2ce978..0c2a2a96e 100644
I_StartupJoysticks();
--
-2.25.0
+2.28.0
diff --git a/PKGBUILD b/PKGBUILD
index a7bd7744f7fa..6c2036ec233e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=raze
pkgver=0.6.0
-pkgrel=2
+pkgrel=3
pkgdesc='Build engine port backed by GZDoom tech'
arch=('x86_64')
url='https://github.com/coelckers/Raze'
@@ -25,7 +25,7 @@ source=("Raze::git+https://github.com/coelckers/Raze#tag=${pkgver}"
'0001-Fix-file-paths.patch'
'raze.desktop')
sha256sums=('SKIP'
- 'cb6a0ff91f3746a1bd9583540f51e3c3ad445a34b1a2a0a46d18a64797223e68'
+ '09502741573bba7f8f8f91b74ecf88dd82d030ed0b185e72dee1cff51a17ec92'
'ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8')
prepare() {