summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2020-02-12 14:41:45 +0100
committerJan Cholasta2020-02-12 14:43:32 +0100
commitf03aebb4899a3b1b5b1879c0aa6c9a114252408c (patch)
tree5d2e264aee549276bcbf73fbdd6a93bad4747799
parent6cc4a5bb0c376eb3952f7f2c8eeba7202b84a131 (diff)
parentb740a35abb7682fb1366c4dc087a96f8c7884fb3 (diff)
downloadaur-f03aebb4899a3b1b5b1879c0aa6c9a114252408c.tar.gz
raze-0.4.2-1
-rw-r--r--.SRCINFO20
-rw-r--r--0001-Fix-file-paths.patch32
-rw-r--r--PKGBUILD66
3 files changed, 40 insertions, 78 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b55bab85a06e..91dbf10ef5d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,38 +1,30 @@
pkgbase = raze
pkgdesc = Build engine port backed by GZDoom tech
- pkgver = 0.4.0
+ pkgver = 0.4.2
pkgrel = 1
url = https://github.com/coelckers/Raze
- arch = i686
arch = x86_64
license = custom:BUILD
- license = custom:dumb
license = GPL2
makedepends = cmake
makedepends = desktop-file-utils
makedepends = git
- depends = alsa-lib
- depends = fluidsynth>=2
- depends = gtk3
depends = hicolor-icon-theme
depends = libgl
depends = libjpeg
- depends = libsndfile
depends = libvpx
- depends = mpg123
- depends = openal
depends = sdl2
+ depends = zmusic
+ optdepends = gtk3: IWAD selection dialog
optdepends = gxmessage: crash dialog (GNOME)
optdepends = kdialog: crash dialog (KDE)
- optdepends = soundfont-fluid: FluidR3 soundfont for FluidSynth
+ optdepends = openal: in-game sound
optdepends = xorg-xmessage: crash dialog (other)
- provides = raze
- conflicts = raze
- source = Raze::git+https://github.com/coelckers/Raze#commit=0.4.0
+ source = Raze::git+https://github.com/coelckers/Raze#tag=0.4.2
source = 0001-Fix-file-paths.patch
source = raze.desktop
sha256sums = SKIP
- sha256sums = cebea1d7bb84a60c4a3b0961ee5f827f5acf18a015ebc42c2bada31cab273221
+ sha256sums = 35c2a1c652f84a56c6ee5a35ec30f9b2028307ee8e14ed053810a344beafc784
sha256sums = ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8
pkgname = raze
diff --git a/0001-Fix-file-paths.patch b/0001-Fix-file-paths.patch
index 3fd84c7ba08e..0db10f1996f1 100644
--- a/0001-Fix-file-paths.patch
+++ b/0001-Fix-file-paths.patch
@@ -1,29 +1,15 @@
-From 3f0271a0bdfc81c92c255aca95d4fa4241f3cbe4 Mon Sep 17 00:00:00 2001
+From c52a9fd04f97ed11ff441e6754c5bdeeb2f35efd Mon Sep 17 00:00:00 2001
From: Jan Cholasta <jan@cholasta.net>
Date: Thu, 6 Feb 2020 07:59:18 +0100
Subject: [PATCH] Fix file paths
---
- .../mididevices/music_fluidsynth_mididevice.cpp | 2 +-
- source/common/gameconfigfile.cpp | 14 +-------------
- source/common/gamecontrol.cpp | 2 +-
- source/common/music/i_soundfont.cpp | 4 +---
- source/platform/posix/sdl/i_main.cpp | 14 +-------------
- 5 files changed, 5 insertions(+), 31 deletions(-)
+ source/common/gameconfigfile.cpp | 14 +-------------
+ source/common/gamecontrol.cpp | 2 +-
+ source/common/music/i_soundfont.cpp | 4 +---
+ source/platform/posix/sdl/i_main.cpp | 14 +-------------
+ 4 files changed, 4 insertions(+), 30 deletions(-)
-diff --git a/libraries/zmusic/mididevices/music_fluidsynth_mididevice.cpp b/libraries/zmusic/mididevices/music_fluidsynth_mididevice.cpp
-index 16ffa3ab0..fa16c3057 100644
---- a/libraries/zmusic/mididevices/music_fluidsynth_mididevice.cpp
-+++ b/libraries/zmusic/mididevices/music_fluidsynth_mididevice.cpp
-@@ -646,7 +646,7 @@ void Fluid_SetupConfig(const char* patches, std::vector<std::string> &patch_path
- // The following will only be used if no soundfont at all is provided, i.e. even the standard one coming with GZDoom is missing.
- #ifdef __unix__
- // This is the standard location on Ubuntu.
-- Fluid_SetupConfig("/usr/share/sounds/sf2/FluidR3_GS.sf2:/usr/share/sounds/sf2/FluidR3_GM.sf2", patch_paths, false);
-+ Fluid_SetupConfig("/usr/share/soundfonts/FluidR3_GS.sf2:/usr/share/soundfonts/FluidR3_GM.sf2", patch_paths, false);
- #endif
- #ifdef _WIN32
- // On Windows, look for the 4 megabyte patch set installed by Creative's drivers as a default.
diff --git a/source/common/gameconfigfile.cpp b/source/common/gameconfigfile.cpp
index dd4c0889e..949e6be16 100644
--- a/source/common/gameconfigfile.cpp
@@ -71,7 +57,7 @@ index dd4c0889e..949e6be16 100644
}
diff --git a/source/common/gamecontrol.cpp b/source/common/gamecontrol.cpp
-index fd38c2fdf..c424ba57e 100644
+index dac122893..111f1f954 100644
--- a/source/common/gamecontrol.cpp
+++ b/source/common/gamecontrol.cpp
@@ -584,7 +584,7 @@ int RunGame()
@@ -84,10 +70,10 @@ index fd38c2fdf..c424ba57e 100644
if (logfile.IsNotEmpty())
{
diff --git a/source/common/music/i_soundfont.cpp b/source/common/music/i_soundfont.cpp
-index 5d911a200..ce05a5463 100644
+index 672ec9268..046c52b7b 100644
--- a/source/common/music/i_soundfont.cpp
+++ b/source/common/music/i_soundfont.cpp
-@@ -243,9 +243,7 @@ FPatchSetReader::FPatchSetReader(const char *filename)
+@@ -230,9 +230,7 @@ FPatchSetReader::FPatchSetReader(const char *filename)
#ifndef _WIN32
mCaseSensitivePaths = true;
const char *paths[] = {
diff --git a/PKGBUILD b/PKGBUILD
index 84f9374b276a..da930fe7173f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,72 +1,56 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
pkgname=raze
-pkgver=0.4.0
+pkgver=0.4.2
pkgrel=1
pkgdesc='Build engine port backed by GZDoom tech'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://github.com/coelckers/Raze'
-license=('custom:BUILD' 'custom:dumb' 'GPL2')
-depends=('alsa-lib'
- 'fluidsynth>=2'
- 'gtk3'
- 'hicolor-icon-theme'
+license=('custom:BUILD' 'GPL2')
+depends=('hicolor-icon-theme'
'libgl'
'libjpeg'
- 'libsndfile'
'libvpx'
- 'mpg123'
- 'openal'
- 'sdl2')
+ 'sdl2'
+ 'zmusic')
makedepends=('cmake'
'desktop-file-utils'
'git')
-optdepends=('gxmessage: crash dialog (GNOME)'
+optdepends=('gtk3: IWAD selection dialog'
+ 'gxmessage: crash dialog (GNOME)'
'kdialog: crash dialog (KDE)'
- 'soundfont-fluid: FluidR3 soundfont for FluidSynth'
+ 'openal: in-game sound'
'xorg-xmessage: crash dialog (other)')
-provides=('raze')
-conflicts=('raze')
-_srcver=$pkgver
-source=("Raze::git+https://github.com/coelckers/Raze#commit=${_srcver}"
+source=("Raze::git+https://github.com/coelckers/Raze#tag=${pkgver}"
'0001-Fix-file-paths.patch'
'raze.desktop')
sha256sums=('SKIP'
- 'cebea1d7bb84a60c4a3b0961ee5f827f5acf18a015ebc42c2bada31cab273221'
+ '35c2a1c652f84a56c6ee5a35ec30f9b2028307ee8e14ed053810a344beafc784'
'ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8')
-pkgver() {
- cd Raze
-
- git describe --tags | tr - +
-}
-
prepare() {
cd Raze
-
- patch -p1 -i"$srcdir"/0001-Fix-file-paths.patch
+ patch -i "$srcdir"/0001-Fix-file-paths.patch -p 1
}
build() {
cd Raze
-
+ mkdir -p build
local _cflags="-ffile-prefix-map=\"$PWD\"=."
- cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_C_FLAGS="${CFLAGS} ${_cflags}" \
- -DCMAKE_CXX_FLAGS="${CXXFLAGS} ${_cflags}" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DINSTALL_PK3_PATH=lib/raze \
- .
- make
+ cmake -B build \
+ -D CMAKE_BUILD_TYPE=Release \
+ -D CMAKE_C_FLAGS="${CFLAGS} ${_cflags}" \
+ -D CMAKE_CXX_FLAGS="${CXXFLAGS} ${_cflags}" \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D ZMUSIC_LIBRARIES=/usr/lib/libzmusic.so \
+ -D INSTALL_PK3_PATH=lib/raze
+ make -C build
}
package() {
cd Raze
-
- make install DESTDIR="$pkgdir"
-
- desktop-file-install --dir="$pkgdir"/usr/share/applications "$srcdir"/raze.desktop
- install -D -m644 source/platform/posix/game.xpm "$pkgdir"/usr/share/icons/hicolor/256x256/apps/raze.xpm
- install -D -m644 package/common/buildlic.txt "$pkgdir"/usr/share/licenses/$pkgname/buildlic.txt
- install -D -m644 libraries/dumb/licence.txt "$pkgdir"/usr/share/licenses/$pkgname/dumb.txt
+ make -C build install DESTDIR="$pkgdir"
+ desktop-file-install "$srcdir"/raze.desktop --dir="$pkgdir"/usr/share/applications
+ install source/platform/posix/game.xpm "$pkgdir"/usr/share/icons/hicolor/256x256/apps/raze.xpm -D -m 644
+ install package/common/buildlic.txt "$pkgdir"/usr/share/licenses/$pkgname/buildlic.txt -D -m 644
}