summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2020-02-06 09:23:56 +0100
committerJan Cholasta2020-02-06 09:23:56 +0100
commit779fc32bcec387d26997adcbcb19541b68a0e25a (patch)
tree4019a339109eef99f258b1711663259fee98ef4c
parent6f31ce8ec83ce32f22ec251c8078e865ec7f1c81 (diff)
downloadaur-779fc32bcec387d26997adcbcb19541b68a0e25a.tar.gz
raze-git-0.4.0+9+g67a2952ea-1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49cbdcfcc838..a0335e00c87b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -28,7 +28,7 @@ pkgbase = raze-git
optdepends = xorg-xmessage: crash dialog (other)
provides = raze
conflicts = raze
- source = Raze-master::git+https://github.com/coelckers/Raze
+ source = Raze-master::git+https://github.com/coelckers/Raze#commit=master
source = 0001-Fix-file-paths.patch
source = raze.desktop
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 03643dca4480..90a84b14af65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,7 +27,9 @@ optdepends=('gxmessage: crash dialog (GNOME)'
'xorg-xmessage: crash dialog (other)')
provides=('raze')
conflicts=('raze')
-source=('Raze-master::git+https://github.com/coelckers/Raze'
+_srcname=Raze
+_srcver=master
+source=("${_srcname}-${_srcver}::git+https://github.com/coelckers/${_srcname}#commit=${_srcver}"
'0001-Fix-file-paths.patch'
'raze.desktop')
sha256sums=('SKIP'
@@ -35,19 +37,19 @@ sha256sums=('SKIP'
'ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8')
pkgver() {
- cd Raze-master
+ cd ${_srcname}-${_srcver}
- git describe --long --tags | tr - +
+ git describe --tags | tr - +
}
prepare() {
- cd Raze-master
+ cd ${_srcname}-${_srcver}
patch -p1 -i"$srcdir"/0001-Fix-file-paths.patch
}
build() {
- cd Raze-master
+ cd ${_srcname}-${_srcver}
local _cflags="-ffile-prefix-map=\"$PWD\"=."
cmake -DCMAKE_BUILD_TYPE=Release \
@@ -60,7 +62,7 @@ build() {
}
package() {
- cd Raze-master
+ cd ${_srcname}-${_srcver}
make install DESTDIR="$pkgdir"