summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2020-02-06 09:28:37 +0100
committerJan Cholasta2020-02-06 09:32:49 +0100
commitd0dd24619b51718a8af61e33f3d86ba56c17cae6 (patch)
treeee3c2c530d61c345d804fcdc5c3dd81cf4e7af6b
parent779fc32bcec387d26997adcbcb19541b68a0e25a (diff)
downloadaur-d0dd24619b51718a8af61e33f3d86ba56c17cae6.tar.gz
raze-git-0.4.0+9+g67a2952ea-1
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD11
3 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0335e00c87b..15c5dda70658 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -28,7 +28,7 @@ pkgbase = raze-git
optdepends = xorg-xmessage: crash dialog (other)
provides = raze
conflicts = raze
- source = Raze-master::git+https://github.com/coelckers/Raze#commit=master
+ source = Raze::git+https://github.com/coelckers/Raze#commit=master
source = 0001-Fix-file-paths.patch
source = raze.desktop
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
index 489478149b22..67ef0e97bb09 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-/Raze-*
+/Raze
/pkg/
/src/
/*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 90a84b14af65..f24b8dd9932d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,9 +27,8 @@ optdepends=('gxmessage: crash dialog (GNOME)'
'xorg-xmessage: crash dialog (other)')
provides=('raze')
conflicts=('raze')
-_srcname=Raze
_srcver=master
-source=("${_srcname}-${_srcver}::git+https://github.com/coelckers/${_srcname}#commit=${_srcver}"
+source=("Raze::git+https://github.com/coelckers/Raze#commit=${_srcver}"
'0001-Fix-file-paths.patch'
'raze.desktop')
sha256sums=('SKIP'
@@ -37,19 +36,19 @@ sha256sums=('SKIP'
'ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8')
pkgver() {
- cd ${_srcname}-${_srcver}
+ cd Raze
git describe --tags | tr - +
}
prepare() {
- cd ${_srcname}-${_srcver}
+ cd Raze
patch -p1 -i"$srcdir"/0001-Fix-file-paths.patch
}
build() {
- cd ${_srcname}-${_srcver}
+ cd Raze
local _cflags="-ffile-prefix-map=\"$PWD\"=."
cmake -DCMAKE_BUILD_TYPE=Release \
@@ -62,7 +61,7 @@ build() {
}
package() {
- cd ${_srcname}-${_srcver}
+ cd Raze
make install DESTDIR="$pkgdir"