summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2017-07-01 18:58:54 +0200
committerLuca Weiss2017-07-01 18:58:54 +0200
commit3060fa9b41cf6d7c87696ccabadedc151693d30d (patch)
treed26291d711c3c0dec5b7c5308f1734dfa6a0c1eb
parentdf18cd4df0e403deab3ba40e7fa62512b589c9bb (diff)
downloadaur-3060fa9b41cf6d7c87696ccabadedc151693d30d.tar.gz
1.1.14
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD5
-rw-r--r--razer-daemon.install12
3 files changed, 20 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d47ae2e24a2b..25e638d80b8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Jun 11 16:34:01 UTC 2017
+# Sat Jul 1 16:58:11 UTC 2017
pkgbase = razer-drivers
pkgdesc = An entirely open source driver and user-space daemon that allows you to manage your Razer peripherals on GNU/Linux.
- pkgver = 1.1.13
+ pkgver = 1.1.14
pkgrel = 1
url = https://github.com/terrycain/razer-drivers
arch = any
@@ -10,8 +10,8 @@ pkgbase = razer-drivers
makedepends = make
makedepends = python
makedepends = python-setuptools
- source = https://github.com/terrycain/razer-drivers/archive/v1.1.13.tar.gz
- sha256sums = 33938e72e8815db90f08001ce3e34fa6cc7e78979f57a914ab5f152c8c90a42e
+ source = https://github.com/terrycain/razer-drivers/archive/v1.1.14.tar.gz
+ sha256sums = a8ca390f29ecc5d220df8ef00b2bebb54b0ef4551ba2e0245296bb72eb461f41
pkgname = python-razer
pkgdesc = Python library for accessing the Razer daemon from Python.
@@ -22,6 +22,7 @@ pkgname = python-razer
pkgname = razer-daemon
pkgdesc = Userspace daemon that abstracts access to the kernel driver. Provides a DBus service for applications to use.
+ install = razer-daemon.install
depends = razer-driver-dkms
depends = python-dbus
depends = python-gobject
diff --git a/PKGBUILD b/PKGBUILD
index 10fcca844e57..41b2a39330e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ if $build_kernel_modules; then
_linux_next=4.12
pkgname+=('razer-driver-arch')
fi
-pkgver=1.1.13
+pkgver=1.1.14
#_commit=6ae1f7d55bf10cc6b5cb62a5ce99ff22c43e0701
pkgrel=1
pkgdesc="An entirely open source driver and user-space daemon that allows you to manage your Razer peripherals on GNU/Linux."
@@ -31,7 +31,7 @@ if [ -z $_commit ]; then
else
source=("https://github.com/terrycain/razer-drivers/archive/$_commit.tar.gz")
fi
-sha256sums=('33938e72e8815db90f08001ce3e34fa6cc7e78979f57a914ab5f152c8c90a42e')
+sha256sums=('a8ca390f29ecc5d220df8ef00b2bebb54b0ef4551ba2e0245296bb72eb461f41')
package_python-razer() {
pkgdesc="Python library for accessing the Razer daemon from Python."
@@ -48,6 +48,7 @@ package_razer-daemon() {
pkgdesc="Userspace daemon that abstracts access to the kernel driver. Provides a DBus service for applications to use."
depends=('razer-driver-dkms' 'python-dbus' 'python-gobject' 'python-setproctitle' 'xautomation' 'xdotool' 'libdbus' 'python-notify2' 'python-pyudev' 'gtk3' 'dbus-glib')
# gtk3 for "gi.require_version('Gdk', '3.0')"
+ install=razer-daemon.install
if [ -z $_commit ]; then
cd $srcdir/$pkgbase-$pkgver
diff --git a/razer-daemon.install b/razer-daemon.install
new file mode 100644
index 000000000000..4ecd532aeb78
--- /dev/null
+++ b/razer-daemon.install
@@ -0,0 +1,12 @@
+msg() {
+ echo "==> You might want to enable razer-daemon.service with the command \"systemctl --user enable --now razer-daemon.service\""
+}
+
+post_upgrade() {
+ msg
+}
+
+post_install() {
+ msg
+}
+