summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2018-05-30 14:31:25 -0700
committerMike Swanson2018-05-30 14:31:52 -0700
commit1a1d5d4a0efc904c3628c283ddf2b20d79d5b76d (patch)
tree1192733b3d2ffaea53045cdc75b7d907b3d8ee99
parentb66d9a54fde5bbef336a417c2888407dd470ff04 (diff)
downloadaur-1a1d5d4a0efc904c3628c283ddf2b20d79d5b76d.tar.gz
Update to new snapshot, fix compilation
-rw-r--r--.SRCINFO12
-rw-r--r--80-gcc7.patch92
-rw-r--r--90-doomclassic-build.patch13
-rw-r--r--PKGBUILD14
4 files changed, 122 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 134241b91c4d..c896818162fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Dec 1 01:02:41 UTC 2017
+# Wed May 30 21:31:39 UTC 2018
pkgbase = rbdoom-3-bfg
pkgdesc = Enhanced Doom 3: BFG Edition engine
- pkgver = 1.1.0preview3.r119.gd7516901
+ pkgver = 1.1.0preview3.r122.g0e2890f9
pkgrel = 1
url = https://github.com/RobertBeckebans/RBDOOM-3-BFG
install = rbdoom-3-bfg.install
@@ -22,7 +22,7 @@ pkgbase = rbdoom-3-bfg
optdepends = alsa-plugins: pulseaudio-support
optdepends = libpulse: pulseaudio support
conflicts = rbdoom3-bfg-git
- source = https://github.com/RobertBeckebans/RBDOOM-3-BFG/archive/d75169010b834196f39cfc3ca4c1358ee277e520.tar.gz
+ source = https://github.com/RobertBeckebans/RBDOOM-3-BFG/archive/0e2890f923398761ddd571c817226ee888adce5c.tar.gz
source = rbdoom-3-bfg.desktop
source = 20-reproducible.patch
source = 30-init-sdl2.patch
@@ -30,7 +30,9 @@ pkgbase = rbdoom-3-bfg
source = 50-system-rapidjson.patch
source = 60-spelling-errors.patch
source = 70-disable-hdr-by-default.patch
- sha512sums = 3d3a423519b4881db748e10f2bc15976938f059ee044902cc0f4c6316ed75467a3f85cd631e0d182dbfba3b636e69bdb5a8c82b305da3a2c5fb2c6db1c16d98b
+ source = 80-gcc7.patch
+ source = 90-doomclassic-build.patch
+ sha512sums = 3adf47fc15819f7bd60d2f8b0cc14134d3c51301397a170b4f3b6da1560ca27027f7bb1e34526c93cc9d924d2b6d9d1065d2b2c25e3f18beaeb089fafd5f8278
sha512sums = f1a74a79c369bec1c371eb74f7e8c415b4d1993fae995b0e476eb7c7e3b0a42dfb8ee5ae1f2e960c1443603f36abe37409ffeac0c29fd085ef5045388ff905f8
sha512sums = db8c51b9bcdb35e81bdc8c5a0ba2575060948ed2fb9837f92cfb9ff73b5f709d8f0909b12cc7715d72dad91cf79d769fd27817c8442bf642af967b1d237974fd
sha512sums = c60b508f5f5c3e19a0ef2431b3d2119b405e8f610356a98c931c16a53ac1b319c485ebe9d454b884a6d66829573377e3f94220bc50dc70efde45c9312f172859
@@ -38,6 +40,8 @@ pkgbase = rbdoom-3-bfg
sha512sums = f7ca60ca455be6cfc7a1367edc3850a97b701e3f3d34ebe67d7f8a2b5412d5006fc7554712147cba450d7de0b4fab18a4eb292ca88272dc4ecc3a9462428bc16
sha512sums = bc1f8bf5ae2025d776080ec41496a16c3e09b1737d4f1c1f76bddb48f97a394dda3ba1f6e08ac8c5d8731a4acc5212a43f90daf41ba7d0f50f8dba5dc18b1069
sha512sums = 6cdf1650709a85cc96a57bc1e6fa127fa6b25ac980984a9f60f77daf4a761589a41eaff61fd7ca9946218a20edd835f4fb28d9844cbac8e6b28769ff149e6dec
+ sha512sums = 5b473c8fa55c53d57044e0a1713443f2012c8e88e7f6349eb9e81f482e6ca958b501e95c88f55cac74dca84b3c015414617dfdb159c08d17d134543d7da5dc74
+ sha512sums = b2eecd0cf8c5d3a037695989d93d6ec3bb504cc31cda01a8a24f7867db171419282d6d6d9a0accbac94558bf5b7884bc4428a5af532ebe23849740cfaff1e974
pkgname = rbdoom-3-bfg
diff --git a/80-gcc7.patch b/80-gcc7.patch
new file mode 100644
index 000000000000..facb206aaa8a
--- /dev/null
+++ b/80-gcc7.patch
@@ -0,0 +1,92 @@
+Description: Fix compilation errors with gcc7
+Author: Tobias Frost <tobi@debian.org>
+Bug-Debian: https://bugs.debian.org/853638
+Last-Update: 2018-04-06
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+diff --git a/doomclassic/doom/wi_stuff.cpp b/doomclassic/doom/wi_stuff.cpp
+index 47837cf..cec5156 100644
+--- a/doomclassic/doom/wi_stuff.cpp
++++ b/doomclassic/doom/wi_stuff.cpp
+@@ -1551,7 +1553,8 @@ void WI_loadData(void)
+ ::g->lnames = (patch_t **) DoomLib::Z_Malloc(sizeof(patch_t*) * ( NUMMAPS ), PU_LEVEL_SHARED, 0);
+ for (i=0 ; i<NUMMAPS ; i++)
+ {
+- sprintf(name, "WILV%d%d", ::g->wbs->epsd, i);
++ snprintf(name, 20, "WILV%d%d", ::g->wbs->epsd, i);
++ name[19] = 0;
+ ::g->lnames[i] = (patch_t*)W_CacheLumpName(name, PU_LEVEL_SHARED);
+ }
+
+@@ -1594,7 +1598,7 @@ void WI_loadData(void)
+ for (i=0;i<10;i++)
+ {
+ // numbers 0-9
+- sprintf(name, "WINUM%d", i);
++ snprintf(name, 10, "WINUM%d", i); name[9] = 0;
+ ::g->num[i] = (patch_t*)W_CacheLumpName(name, PU_LEVEL_SHARED);
+ }
+
+@@ -1651,11 +1655,11 @@ void WI_loadData(void)
+ for (i=0 ; i<MAXPLAYERS ; i++)
+ {
+ // "1,2,3,4"
+- sprintf(name, "STPB%d", i);
++ snprintf(name, 10, "STPB%d", i); name[9] = 0;
+ ::g->wistuff_p[i] = (patch_t*)W_CacheLumpName(name, PU_LEVEL_SHARED);
+
+ // "1,2,3,4"
+- sprintf(name, "WIBP%d", i+1);
++ snprintf(name, 10, "WIBP%d", i+1); name[9] = 0;
+ ::g->wistuff_bp[i] = (patch_t*)W_CacheLumpName(name, PU_LEVEL_SHARED);
+ }
+
+diff --git a/neo/d3xp/MultiplayerGame.cpp b/neo/d3xp/MultiplayerGame.cpp
+index a14c6da..4780f95 100644
+--- a/neo/d3xp/MultiplayerGame.cpp
++++ b/neo/d3xp/MultiplayerGame.cpp
+@@ -631,7 +631,8 @@ idMultiplayerGame::GameTime
+ const char* idMultiplayerGame::GameTime()
+ {
+ static char buff[16];
+- int m, s, t, ms;
++ unsigned int m, s, t;
++ int ms;
+
+ if( gameState == COUNTDOWN )
+ {
+@@ -653,7 +654,9 @@ const char* idMultiplayerGame::GameTime()
+ }
+ else
+ {
+- sprintf( buff, "WMP %i", s );
++ snprintf( buff, 16, "WMP %i", s );
++ buff[15] = 0;
++
+ }
+ }
+ else
+diff --git a/neo/tools/compilers/dmap/dmap.cpp b/neo/tools/compilers/dmap/dmap.cpp
+index 655e881..03c5831 100644
+--- a/neo/tools/compilers/dmap/dmap.cpp
++++ b/neo/tools/compilers/dmap/dmap.cpp
+@@ -34,6 +34,10 @@ If you have questions concerning this license or the applicable additional terms
+
+ dmapGlobals_t dmapGlobals;
+
++#ifndef PATH_MAX
++#define PATH_MAX 4096
++#endif
++
+ /*
+ ============
+ ProcessModel
+@@ -243,7 +247,7 @@ void Dmap( const idCmdArgs& args )
+ {
+ int i;
+ int start, end;
+- char path[1024];
++ char path[PATH_MAX];
+ idStr passedName;
+ bool leaked = false;
+ bool noCM = false;
diff --git a/90-doomclassic-build.patch b/90-doomclassic-build.patch
new file mode 100644
index 000000000000..1dabd509965a
--- /dev/null
+++ b/90-doomclassic-build.patch
@@ -0,0 +1,13 @@
+diff --git a/doomclassic/doom/p_setup.cpp b/doomclassic/doom/p_setup.cpp
+index d0aceff..8e064c0 100644
+--- a/doomclassic/doom/p_setup.cpp
++++ b/doomclassic/doom/p_setup.cpp
+@@ -655,7 +655,7 @@ P_SetupLevel
+ // find map name
+ if ( ::g->gamemode == commercial)
+ {
+- if (map<10)
++ if (map % 100 < 10)
+ sprintf (lumpname,"map0%i", map);
+ else
+ sprintf (lumpname,"map%i", map);
diff --git a/PKGBUILD b/PKGBUILD
index d743ea8351b7..da6b29cffef7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Based on the rbdoom3-bfg-git package by M0Rf30
pkgname=rbdoom-3-bfg
-_commit=d75169010b834196f39cfc3ca4c1358ee277e520
-pkgver=1.1.0preview3.r119.gd7516901
+_commit=0e2890f923398761ddd571c817226ee888adce5c
+pkgver=1.1.0preview3.r122.g0e2890f9
pkgrel=1
pkgdesc="Enhanced Doom 3: BFG Edition engine"
arch=('i686' 'x86_64')
@@ -23,15 +23,19 @@ source=("https://github.com/RobertBeckebans/RBDOOM-3-BFG/archive/${_commit}.tar.
40-libpng16.patch
50-system-rapidjson.patch
60-spelling-errors.patch
- 70-disable-hdr-by-default.patch)
-sha512sums=('3d3a423519b4881db748e10f2bc15976938f059ee044902cc0f4c6316ed75467a3f85cd631e0d182dbfba3b636e69bdb5a8c82b305da3a2c5fb2c6db1c16d98b'
+ 70-disable-hdr-by-default.patch
+ 80-gcc7.patch
+ 90-doomclassic-build.patch)
+sha512sums=('3adf47fc15819f7bd60d2f8b0cc14134d3c51301397a170b4f3b6da1560ca27027f7bb1e34526c93cc9d924d2b6d9d1065d2b2c25e3f18beaeb089fafd5f8278'
'f1a74a79c369bec1c371eb74f7e8c415b4d1993fae995b0e476eb7c7e3b0a42dfb8ee5ae1f2e960c1443603f36abe37409ffeac0c29fd085ef5045388ff905f8'
'db8c51b9bcdb35e81bdc8c5a0ba2575060948ed2fb9837f92cfb9ff73b5f709d8f0909b12cc7715d72dad91cf79d769fd27817c8442bf642af967b1d237974fd'
'c60b508f5f5c3e19a0ef2431b3d2119b405e8f610356a98c931c16a53ac1b319c485ebe9d454b884a6d66829573377e3f94220bc50dc70efde45c9312f172859'
'efd74dacb3cdd28b7d78b348e884de0e23170908504f32f1dad2ded81c49a1c7e3b0f80da4fca96c14e52c4aeb2c4591a5877ada81ea2fcd3ab9e59b78d3989e'
'f7ca60ca455be6cfc7a1367edc3850a97b701e3f3d34ebe67d7f8a2b5412d5006fc7554712147cba450d7de0b4fab18a4eb292ca88272dc4ecc3a9462428bc16'
'bc1f8bf5ae2025d776080ec41496a16c3e09b1737d4f1c1f76bddb48f97a394dda3ba1f6e08ac8c5d8731a4acc5212a43f90daf41ba7d0f50f8dba5dc18b1069'
- '6cdf1650709a85cc96a57bc1e6fa127fa6b25ac980984a9f60f77daf4a761589a41eaff61fd7ca9946218a20edd835f4fb28d9844cbac8e6b28769ff149e6dec')
+ '6cdf1650709a85cc96a57bc1e6fa127fa6b25ac980984a9f60f77daf4a761589a41eaff61fd7ca9946218a20edd835f4fb28d9844cbac8e6b28769ff149e6dec'
+ '5b473c8fa55c53d57044e0a1713443f2012c8e88e7f6349eb9e81f482e6ca958b501e95c88f55cac74dca84b3c015414617dfdb159c08d17d134543d7da5dc74'
+ 'b2eecd0cf8c5d3a037695989d93d6ec3bb504cc31cda01a8a24f7867db171419282d6d6d9a0accbac94558bf5b7884bc4428a5af532ebe23849740cfaff1e974')
prepare() {
cd "$srcdir/RBDOOM-3-BFG-$_commit"