summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2017-09-06 20:57:09 -0700
committerMike Swanson2017-09-06 20:57:09 -0700
commiteadf32c5a1270530d1ed70b3671461b3a5c177c1 (patch)
treed9c8dacb7b644fbd806fbcd80d7fef48d024e490
parent869fb205c6b6c3c85e824cc89ebb7d746967f4f1 (diff)
downloadaur-eadf32c5a1270530d1ed70b3671461b3a5c177c1.tar.gz
Update to latest repo commit, includes GCC7 fix
-rw-r--r--.SRCINFO12
-rw-r--r--80-gcc7.patch221
-rw-r--r--PKGBUILD14
3 files changed, 11 insertions, 236 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df3a96974d17..2bd0f6142aab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Aug 27 04:48:00 UTC 2017
+# Thu Sep 7 03:50:18 UTC 2017
pkgbase = rbdoom-3-bfg
pkgdesc = Doom 3 BFG source code (Robert Beckebans repo).
- pkgver = 1.1.0preview3.r98.e5b3c697
- pkgrel = 2
+ pkgver = 1.1.0preview3.r115.gc8e3cd9f
+ pkgrel = 1
url = https://github.com/RobertBeckebans/RBDOOM-3-BFG
install = rbdoom-3-bfg.install
arch = i686
@@ -22,7 +22,7 @@ pkgbase = rbdoom-3-bfg
optdepends = alsa-plugins: pulseaudio-support
optdepends = libpulse: pulseaudio support
conflicts = rbdoom3-bfg-git
- source = https://github.com/RobertBeckebans/RBDOOM-3-BFG/archive/e5b3c697d23b9a90c654181162fe476c8c4f90d9.tar.gz
+ source = https://github.com/RobertBeckebans/RBDOOM-3-BFG/archive/c8e3cd9fe2f4d3e7604f0ca1ead51a3b2a91ca79.tar.gz
source = rbdoom-3-bfg.desktop
source = 20-reproducible.patch
source = 30-init-sdl2.patch
@@ -30,8 +30,7 @@ pkgbase = rbdoom-3-bfg
source = 50-system-rapidjson.patch
source = 60-spelling-errors.patch
source = 70-disable-hdr-by-default.patch
- source = 80-gcc7.patch
- sha512sums = 3773935aa7684dca0e1f310f8c23afc61000d5bb9e579361df9113c0be12e5e1f5b5af4719461a0b6868ddb47a7e84d812b494a14e8993a0cf3f5d60a3094a8a
+ sha512sums = e20b2e86c9b9f12268401aae075bb648708ff7b21d17d92cf431182e1fe823959c59b2fb2d52a96e00bd4fa632983f3b347e9d4db85fee44b62f6401c7dd777e
sha512sums = f1a74a79c369bec1c371eb74f7e8c415b4d1993fae995b0e476eb7c7e3b0a42dfb8ee5ae1f2e960c1443603f36abe37409ffeac0c29fd085ef5045388ff905f8
sha512sums = db8c51b9bcdb35e81bdc8c5a0ba2575060948ed2fb9837f92cfb9ff73b5f709d8f0909b12cc7715d72dad91cf79d769fd27817c8442bf642af967b1d237974fd
sha512sums = c60b508f5f5c3e19a0ef2431b3d2119b405e8f610356a98c931c16a53ac1b319c485ebe9d454b884a6d66829573377e3f94220bc50dc70efde45c9312f172859
@@ -39,7 +38,6 @@ pkgbase = rbdoom-3-bfg
sha512sums = f7ca60ca455be6cfc7a1367edc3850a97b701e3f3d34ebe67d7f8a2b5412d5006fc7554712147cba450d7de0b4fab18a4eb292ca88272dc4ecc3a9462428bc16
sha512sums = bc1f8bf5ae2025d776080ec41496a16c3e09b1737d4f1c1f76bddb48f97a394dda3ba1f6e08ac8c5d8731a4acc5212a43f90daf41ba7d0f50f8dba5dc18b1069
sha512sums = 6cdf1650709a85cc96a57bc1e6fa127fa6b25ac980984a9f60f77daf4a761589a41eaff61fd7ca9946218a20edd835f4fb28d9844cbac8e6b28769ff149e6dec
- sha512sums = 884ac7ae61b780042b012bbc1d702260533768edc466572dd6b35568966e1d837d7d6a43e77e7b1f7405b71871d55971d3d236df19f59110b8fa39e18b5b4b9f
pkgname = rbdoom-3-bfg
diff --git a/80-gcc7.patch b/80-gcc7.patch
deleted file mode 100644
index 6ea6cf786e95..000000000000
--- a/80-gcc7.patch
+++ /dev/null
@@ -1,221 +0,0 @@
-diff --git a/doomclassic/doom/st_stuff.cpp b/doomclassic/doom/st_stuff.cpp
-index 481ec82..baeaf01 100644
---- a/doomclassic/doom/st_stuff.cpp
-+++ b/doomclassic/doom/st_stuff.cpp
-@@ -968,7 +968,7 @@ void ST_loadGraphics(void)
- int j;
- int facenum;
-
-- char namebuf[9];
-+ char namebuf[11];
-
- // Load the numbers, tall and short
- for (i=0;i<10;i++)
-diff --git a/doomclassic/doom/wi_stuff.cpp b/doomclassic/doom/wi_stuff.cpp
-index 47837cf..cec5156 100644
---- a/doomclassic/doom/wi_stuff.cpp
-+++ b/doomclassic/doom/wi_stuff.cpp
-@@ -1503,16 +1503,17 @@ void WI_loadData(void)
- {
- int i;
- int j;
-- char name[9];
-+ char name[20];
- anim_t* a;
-
-- if (::g->gamemode == commercial)
-+ if (::g->gamemode == commercial) {
- strcpy(name, "INTERPIC");
- // DHM - Nerve :: Use our background image
- //strcpy(name, "DMENUPIC");
-- else
-- sprintf(name, "WIMAP%d", ::g->wbs->epsd);
--
-+ } else {
-+ snprintf(name, 20, "WIMAP%d", ::g->wbs->epsd);
-+ name[19] = 0;
-+ }
- if ( ::g->gamemode == retail )
- {
- if (::g->wbs->epsd == 3)
-@@ -1542,7 +1543,8 @@ void WI_loadData(void)
- ::g->lnames = (patch_t **) DoomLib::Z_Malloc(sizeof(patch_t*) * ::g->NUMCMAPS, PU_LEVEL_SHARED, 0);
- for (i=0 ; i < ::g->NUMCMAPS ; i++)
- {
-- sprintf(name, "CWILV%2.2d", i);
-+ snprintf(name, 20, "CWILV%2.2d", i);
-+ name[19] = 0;
- ::g->lnames[i] = (patch_t*)W_CacheLumpName(name, PU_LEVEL_SHARED);
- }
- }
-@@ -1551,7 +1553,8 @@ void WI_loadData(void)
- ::g->lnames = (patch_t **) DoomLib::Z_Malloc(sizeof(patch_t*) * ( NUMMAPS ), PU_LEVEL_SHARED, 0);
- for (i=0 ; i<NUMMAPS ; i++)
- {
-- sprintf(name, "WILV%d%d", ::g->wbs->epsd, i);
-+ snprintf(name, 20, "WILV%d%d", ::g->wbs->epsd, i);
-+ name[19] = 0;
- ::g->lnames[i] = (patch_t*)W_CacheLumpName(name, PU_LEVEL_SHARED);
- }
-
-@@ -1575,7 +1578,8 @@ void WI_loadData(void)
- if (::g->wbs->epsd != 1 || j != 8)
- {
- // animations
-- sprintf(name, "WIA%d%.2d%.2d", ::g->wbs->epsd, j, i);
-+ snprintf(name, 20, "WIA%d%.2d%.2d", ::g->wbs->epsd, j, i);
-+ name[19] = 0;
- a->p[i] = (patch_t*)W_CacheLumpName(name, PU_LEVEL_SHARED);
- }
- else
-@@ -1594,7 +1598,7 @@ void WI_loadData(void)
- for (i=0;i<10;i++)
- {
- // numbers 0-9
-- sprintf(name, "WINUM%d", i);
-+ snprintf(name, 10, "WINUM%d", i); name[9] = 0;
- ::g->num[i] = (patch_t*)W_CacheLumpName(name, PU_LEVEL_SHARED);
- }
-
-@@ -1651,11 +1655,11 @@ void WI_loadData(void)
- for (i=0 ; i<MAXPLAYERS ; i++)
- {
- // "1,2,3,4"
-- sprintf(name, "STPB%d", i);
-+ snprintf(name, 10, "STPB%d", i); name[9] = 0;
- ::g->wistuff_p[i] = (patch_t*)W_CacheLumpName(name, PU_LEVEL_SHARED);
-
- // "1,2,3,4"
-- sprintf(name, "WIBP%d", i+1);
-+ snprintf(name, 10, "WIBP%d", i+1); name[9] = 0;
- ::g->wistuff_bp[i] = (patch_t*)W_CacheLumpName(name, PU_LEVEL_SHARED);
- }
-
-diff --git a/neo/d3xp/MultiplayerGame.cpp b/neo/d3xp/MultiplayerGame.cpp
-index a14c6da..4780f95 100644
---- a/neo/d3xp/MultiplayerGame.cpp
-+++ b/neo/d3xp/MultiplayerGame.cpp
-@@ -631,7 +631,8 @@ idMultiplayerGame::GameTime
- const char* idMultiplayerGame::GameTime()
- {
- static char buff[16];
-- int m, s, t, ms;
-+ unsigned int m, s, t;
-+ int ms;
-
- if( gameState == COUNTDOWN )
- {
-@@ -653,7 +654,9 @@ const char* idMultiplayerGame::GameTime()
- }
- else
- {
-- sprintf( buff, "WMP %i", s );
-+ snprintf( buff, 16, "WMP %i", s );
-+ buff[15] = 0;
-+
- }
- }
- else
-@@ -678,7 +681,8 @@ const char* idMultiplayerGame::GameTime()
- t = s / 10;
- s -= t * 10;
-
-- sprintf( buff, "%i:%i%i", m, t, s );
-+ snprintf( buff, 16, "%i:%i%i", m, t, s );
-+ buff[15] = 0;
- }
- return &buff[0];
- }
-diff --git a/neo/idlib/StrStatic.h b/neo/idlib/StrStatic.h
-index 4fdb52d..63c930f 100644
---- a/neo/idlib/StrStatic.h
-+++ b/neo/idlib/StrStatic.h
-@@ -97,7 +97,7 @@ public:
- {
- buffer[ 0 ] = '\0';
- SetStaticBuffer( buffer, _size_ );
-- idStr::operator=( b );
-+ idStr::operator=( idStr(b) );
- }
-
- ID_INLINE explicit idStrStatic( const char c ) :
-@@ -105,7 +105,7 @@ public:
- {
- buffer[ 0 ] = '\0';
- SetStaticBuffer( buffer, _size_ );
-- idStr::operator=( c );
-+ idStr::operator=( idStr(c) );
- }
-
- ID_INLINE explicit idStrStatic( const int i ) :
-@@ -113,7 +113,7 @@ public:
- {
- buffer[ 0 ] = '\0';
- SetStaticBuffer( buffer, _size_ );
-- idStr::operator=( i );
-+ idStr::operator=( idStr(i) );
- }
-
- ID_INLINE explicit idStrStatic( const unsigned u ) :
-@@ -121,7 +121,7 @@ public:
- {
- buffer[ 0 ] = '\0';
- SetStaticBuffer( buffer, _size_ );
-- idStr::operator=( u );
-+ idStr::operator=( idStr(u) );
- }
-
- ID_INLINE explicit idStrStatic( const float f ) :
-@@ -129,7 +129,7 @@ public:
- {
- buffer[ 0 ] = '\0';
- SetStaticBuffer( buffer, _size_ );
-- idStr::operator=( f );
-+ idStr::operator=( idStr(f) );
- }
-
- private:
-diff --git a/neo/tools/compilers/dmap/dmap.cpp b/neo/tools/compilers/dmap/dmap.cpp
-index 655e881..03c5831 100644
---- a/neo/tools/compilers/dmap/dmap.cpp
-+++ b/neo/tools/compilers/dmap/dmap.cpp
-@@ -34,6 +34,10 @@ If you have questions concerning this license or the applicable additional terms
-
- dmapGlobals_t dmapGlobals;
-
-+#ifndef PATH_MAX
-+#define PATH_MAX 4096
-+#endif
-+
- /*
- ============
- ProcessModel
-@@ -243,7 +247,7 @@ void Dmap( const idCmdArgs& args )
- {
- int i;
- int start, end;
-- char path[1024];
-+ char path[PATH_MAX];
- idStr passedName;
- bool leaked = false;
- bool noCM = false;
-@@ -390,7 +394,8 @@ void Dmap( const idCmdArgs& args )
- // if this isn't a regioned map, delete the last saved region map
- if( passedName.Right( 4 ) != ".reg" )
- {
-- sprintf( path, "%s.reg", dmapGlobals.mapFileBase );
-+ snprintf( path, PATH_MAX, "%s.reg", dmapGlobals.mapFileBase );
-+ path[PATH_MAX-1] = 0;
- fileSystem->RemoveFile( path );
- }
- else
-@@ -402,7 +407,8 @@ void Dmap( const idCmdArgs& args )
- passedName = stripped;
-
- // delete any old line leak files
-- sprintf( path, "%s.lin", dmapGlobals.mapFileBase );
-+ snprintf( path, PATH_MAX, "%s.lin", dmapGlobals.mapFileBase );
-+ path[PATH_MAX-1] = 0;
- fileSystem->RemoveFile( path );
-
- // delete any old generated binary proc files
diff --git a/PKGBUILD b/PKGBUILD
index 5e4f66a450e2..1990749206d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Based on the rbdoom3-bfg-git package by M0Rf30
pkgname=rbdoom-3-bfg
-_commit=e5b3c697d23b9a90c654181162fe476c8c4f90d9
-pkgver=1.1.0preview3.r98.e5b3c697
-pkgrel=2
+_commit=c8e3cd9fe2f4d3e7604f0ca1ead51a3b2a91ca79
+pkgver=1.1.0preview3.r115.gc8e3cd9f
+pkgrel=1
pkgdesc="Doom 3 BFG source code (Robert Beckebans repo)."
arch=('i686' 'x86_64')
url="https://github.com/RobertBeckebans/RBDOOM-3-BFG"
@@ -23,17 +23,15 @@ source=("https://github.com/RobertBeckebans/RBDOOM-3-BFG/archive/${_commit}.tar.
40-libpng16.patch
50-system-rapidjson.patch
60-spelling-errors.patch
- 70-disable-hdr-by-default.patch
- 80-gcc7.patch)
-sha512sums=('3773935aa7684dca0e1f310f8c23afc61000d5bb9e579361df9113c0be12e5e1f5b5af4719461a0b6868ddb47a7e84d812b494a14e8993a0cf3f5d60a3094a8a'
+ 70-disable-hdr-by-default.patch)
+sha512sums=('e20b2e86c9b9f12268401aae075bb648708ff7b21d17d92cf431182e1fe823959c59b2fb2d52a96e00bd4fa632983f3b347e9d4db85fee44b62f6401c7dd777e'
'f1a74a79c369bec1c371eb74f7e8c415b4d1993fae995b0e476eb7c7e3b0a42dfb8ee5ae1f2e960c1443603f36abe37409ffeac0c29fd085ef5045388ff905f8'
'db8c51b9bcdb35e81bdc8c5a0ba2575060948ed2fb9837f92cfb9ff73b5f709d8f0909b12cc7715d72dad91cf79d769fd27817c8442bf642af967b1d237974fd'
'c60b508f5f5c3e19a0ef2431b3d2119b405e8f610356a98c931c16a53ac1b319c485ebe9d454b884a6d66829573377e3f94220bc50dc70efde45c9312f172859'
'efd74dacb3cdd28b7d78b348e884de0e23170908504f32f1dad2ded81c49a1c7e3b0f80da4fca96c14e52c4aeb2c4591a5877ada81ea2fcd3ab9e59b78d3989e'
'f7ca60ca455be6cfc7a1367edc3850a97b701e3f3d34ebe67d7f8a2b5412d5006fc7554712147cba450d7de0b4fab18a4eb292ca88272dc4ecc3a9462428bc16'
'bc1f8bf5ae2025d776080ec41496a16c3e09b1737d4f1c1f76bddb48f97a394dda3ba1f6e08ac8c5d8731a4acc5212a43f90daf41ba7d0f50f8dba5dc18b1069'
- '6cdf1650709a85cc96a57bc1e6fa127fa6b25ac980984a9f60f77daf4a761589a41eaff61fd7ca9946218a20edd835f4fb28d9844cbac8e6b28769ff149e6dec'
- '884ac7ae61b780042b012bbc1d702260533768edc466572dd6b35568966e1d837d7d6a43e77e7b1f7405b71871d55971d3d236df19f59110b8fa39e18b5b4b9f')
+ '6cdf1650709a85cc96a57bc1e6fa127fa6b25ac980984a9f60f77daf4a761589a41eaff61fd7ca9946218a20edd835f4fb28d9844cbac8e6b28769ff149e6dec')
prepare() {
cd "$srcdir/RBDOOM-3-BFG-$_commit"