summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaizhao Zhang2018-04-19 23:39:05 +0800
committerKaizhao Zhang2018-04-19 23:39:05 +0800
commit5977ee6abe6fe9e2b5fb7159d7382c51d681e973 (patch)
tree1dd1c7385d2e3dc4b118762eeb5f1086997958b7
downloadaur-5977ee6abe6fe9e2b5fb7159d7382c51d681e973.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD17
3 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eba0c95be50b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = rbspy-bin
+ pkgdesc = Sampling profiler for Ruby
+ pkgver = 0.2.6
+ pkgrel = 1
+ url = https://rbspy.github.io
+ arch = x86_64
+ license = MIT
+ provides = rbspy
+ conflicts = rbspy
+ source = https://github.com/rbspy/rbspy/releases/download/v0.2.6/rbspy-v0.2.6-x86_64-unknown-linux-musl.tar.gz
+ sha512sums = d3df312008a567afe714ec5ccde98cbba03ff9ec0668eaae7726f9d14713543457e632645e5b52f60aa370f8acc90234f3f28b7add7a2827d0084e408a87b301
+
+pkgname = rbspy-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..924dfb95c209
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc44eca1cd89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
+
+pkgname=rbspy-bin
+pkgver=0.2.6
+pkgrel=1
+pkgdesc="Sampling profiler for Ruby"
+arch=('x86_64')
+url="https://rbspy.github.io"
+license=('MIT')
+provides=('rbspy')
+conflicts=('rbspy')
+source=("https://github.com/rbspy/rbspy/releases/download/v${pkgver}/rbspy-v${pkgver}-x86_64-unknown-linux-musl.tar.gz")
+sha512sums=('d3df312008a567afe714ec5ccde98cbba03ff9ec0668eaae7726f9d14713543457e632645e5b52f60aa370f8acc90234f3f28b7add7a2827d0084e408a87b301')
+
+package() {
+ install -D -m755 "${srcdir}/rbspy" "${pkgdir}/usr/bin/rbspy"
+}