summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Klitzing2022-05-02 09:37:18 +0200
committerAndré Klitzing2022-05-02 09:37:18 +0200
commit3f675e5c256ba57f5e0969aa418cf09d8fcbfd64 (patch)
tree3011add045536c0a96c8f914d5e01ed153efa06c
parent859ebd0f1edf1e512ba16d0d430cd30db1478f0b (diff)
downloadaur-3f675e5c256ba57f5e0969aa418cf09d8fcbfd64.tar.gz
Use PEP517
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8db57912500..7581198e07e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
pkgbase = rbtools
pkgdesc = Client tools for Review Board
pkgver = 2.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.reviewboard.org/
arch = any
license = custom:MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = python-setuptools
depends = python-six
diff --git a/PKGBUILD b/PKGBUILD
index 299fd1b70982..df3d05b2913f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,24 @@
pkgname=rbtools
_name=RBTools
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Client tools for Review Board"
arch=('any')
url="https://www.reviewboard.org/"
license=('custom:MIT')
-depends=('python' 'python-setuptools' 'python-six' 'python-tqdm' 'python-texttable' 'python-colorama')
+makedepends=(python-build python-installer python-wheel)
+depends=(python python-setuptools python-six python-tqdm python-texttable python-colorama)
source=(https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz)
sha256sums=('df8d5e834ad291c6e743907e27e50fc2f6006cdc6b8a4f9035acc86b87dcba31')
build() {
cd "$srcdir/RBTools-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir/RBTools-$pkgver"
- python setup.py install --root "${pkgdir}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}