summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2022-04-24 20:56:43 +0200
committerYour Name2022-04-24 20:56:43 +0200
commit519c9714a891748e748d07fb96dfd0e04f03b280 (patch)
tree7e62057ea394e1a4ec92016abff319cdc1326bd1
downloadaur-519c9714a891748e748d07fb96dfd0e04f03b280.tar.gz
init
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e84355c8c2d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = rchat
+ pkgdesc = rautafarmi chat client with Vim keybinds written in Bash
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/speediegamer/rchat
+ arch = any
+ license = GPL3
+ depends = bash
+ depends = sed
+ source = https://github.com/speediegamer/rchat/archive/refs/tags/0.3-r1.tar.gz
+ sha256sums = 342f5a8bcb0575417f14f2c6be97e5e85c34f1ef933d5a019fe1b31c3432bd4c
+
+pkgname = rchat
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..409d0e53a69f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+pkgname=rchat
+pkgver=0.3
+pkgrel=1
+pkgdesc="rautafarmi chat client with Vim keybinds written in Bash"
+arch=("any")
+url="https://github.com/speediegamer/rchat"
+license=("GPL3")
+depends=("bash" "sed")
+source=("https://github.com/speediegamer/rchat/archive/refs/tags/$pkgver-r$pkgrel.tar.gz")
+sha256sums=("342f5a8bcb0575417f14f2c6be97e5e85c34f1ef933d5a019fe1b31c3432bd4c")
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ cd "rchat-$pkgver-r$pkgrel"
+ cp "rchat" "$pkgdir/usr/bin"
+ chmod 755 "$pkgdir/usr/bin/rchat"
+}