summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduard Kracmar2015-07-06 11:58:21 +0200
committerSimon Weald2015-08-25 10:59:39 +0100
commit54dcfc4737d55b87bfb87ee5a8a15af13bb50d70 (patch)
treea11434cb0758423aa6393eb0f7f328b09a0c4e4d
downloadaur-54dcfc4737d55b87bfb87ee5a8a15af13bb50d70.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD23
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ec4fdc60c51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = rclone
+ pkgdesc = Rclone is a command line program to sync files and directories to and from Google Drive, Amazon S3, Openstack Swift / Rackspace cloud files / Memset Memstore, Dropbox, Google Cloud Storage and The local filesystem.
+ pkgver = 1.14
+ pkgrel = 2
+ url = http://rclone.org/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ source_i686 = http://downloads.rclone.org/rclone-v1.14-linux-386.zip
+ md5sums_i686 = f86052086f0a135a209a644cf6f726ce
+ source_x86_64 = http://downloads.rclone.org/rclone-v1.14-linux-amd64.zip
+ md5sums_x86_64 = 18bab6c8b5064761d8b1fecf1941205e
+
+pkgname = rclone
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6f1941c77d11
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/*
+src/*
+*.gz
+*.xz
+*.zip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d84f44b64c73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Eduard Kracmar <eduard[at]adaptiware[dot]company>
+
+pkgname=rclone
+pkgver=1.14
+pkgrel=2
+pkgdesc="Rclone is a command line program to sync files and directories to and from Google Drive, Amazon S3, Openstack Swift / Rackspace cloud files / Memset Memstore, Dropbox, Google Cloud Storage and The local filesystem."
+url="http://rclone.org/"
+license=('MIT')
+arch=('i686' 'x86_64')
+_arch='linux-386'
+[ "$CARCH" = 'x86_64' ] && _arch='linux-amd64'
+source_i686=("http://downloads.rclone.org/rclone-v$pkgver-linux-386.zip")
+source_x86_64=("http://downloads.rclone.org/rclone-v$pkgver-linux-amd64.zip")
+md5sums_i686=('f86052086f0a135a209a644cf6f726ce')
+md5sums_x86_64=('18bab6c8b5064761d8b1fecf1941205e')
+
+package() {
+ mkdir -p $pkgdir/usr/bin || return 1
+ cp $srcdir/$pkgname-v$pkgver-$_arch/rclone $pkgdir/usr/bin/$pkgname || return 1
+}
+
+
+