summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2019-12-19 00:11:07 +0100
committerFabioLolix2019-12-19 00:11:07 +0100
commit4878240442b8e2ccbe6d81fb830f302c725b007c (patch)
tree4b0ab86e63be0be9d07591a7db03c58048c5c2f2
parentb16d0fe94d6c9d15931db14473d7785859400cc7 (diff)
downloadaur-4878240442b8e2ccbe6d81fb830f302c725b007c.tar.gz
Source URL change
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD48
2 files changed, 34 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e101c941abb..e733df5cf724 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
pkgbase = rclone-git
pkgdesc = Sync files to and from Google Drive, S3, Swift, Cloudfiles, Dropbox and Google Cloud Storage
- pkgver = 1.41.r8.g50dc5fe9
+ pkgver = 1.50.0.r83.g4537d9b5c
pkgrel = 1
url = http://rclone.org/
arch = i686
arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = MIT
makedepends = git
- makedepends = python2
+ makedepends = python
makedepends = pandoc
makedepends = go-pie
depends = glibc
provides = rclone
conflicts = rclone
- source = rclone-git::git+https://github.com/ncw/rclone.git
+ source = git+https://github.com/rclone/rclone.git
sha256sums = SKIP
pkgname = rclone-git
diff --git a/PKGBUILD b/PKGBUILD
index 5e7f9f75debd..1d390591c6ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,54 +3,60 @@
# Contributor: Felix Yan
pkgname=rclone-git
-pkgver=1.41.r8.g50dc5fe9
+pkgver=1.50.0.r83.g4537d9b5c
pkgrel=1
pkgdesc="Sync files to and from Google Drive, S3, Swift, Cloudfiles, Dropbox and Google Cloud Storage"
-arch=('i686' 'x86_64')
+arch=(i686 x86_64 arm armv6h armv7h aarch64)
url="http://rclone.org/"
-license=('MIT')
-depends=('glibc')
-makedepends=('git' 'python2' 'pandoc' 'go-pie')
-source=("${pkgname}::git+https://github.com/ncw/rclone.git")
-conflicts=('rclone')
-provides=('rclone')
+license=(MIT)
+depends=(glibc)
+makedepends=(git python pandoc go-pie)
+source=("git+https://github.com/rclone/rclone.git")
+conflicts=(rclone)
+provides=(rclone)
sha256sums=('SKIP')
pkgver() {
- cd "${pkgname}"
+ cd "${pkgname%-git}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${pkgname}"
+ cd "${pkgname%-git}"
sed -i "1s/python$/&2/" bin/make_manual.py
- mkdir -p .gopath/src/github.com/ncw
- ln -sf "$PWD" .gopath/src/github.com/ncw/rclone
+ mkdir -p .gopath/src/github.com/rclone
+ ln -sf "$PWD" .gopath/src/github.com/rclone/rclone
export GOPATH="$PWD/.gopath"
- go get github.com/ncw/rclone
+ go get github.com/rclone/rclone
}
build() {
- cd "${pkgname}/.gopath/src/github.com/ncw/rclone"
+ cd "${pkgname%-git}/.gopath/src/github.com/rclone/rclone"
- PATH="$GOPATH/bin:$PATH" make TAG=v$pkgver rclone doc
+ PATH="$GOPATH/bin:$PATH" make TAG=v$pkgver rclone rclone.1 MANUAL.html MANUAL.txt
+
+ ./rclone genautocomplete bash rclone.bash_completion
+ ./rclone genautocomplete zsh rclone.zsh_completion
}
check() {
- cd "${pkgname}/.gopath/src/github.com/ncw/rclone"
+ cd "${pkgname%-git}/.gopath/src/github.com/rclone/rclone"
make TAG=v$pkgver test || warning "Tests failed"
}
package() {
- cd "${pkgname}/.gopath/src/github.com/ncw/rclone"
+ cd "${pkgname%-git}/.gopath/src/github.com/rclone/rclone"
make TAG=v$pkgver DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -Dm644 rclone.bash_completion "$pkgdir"/usr/share/bash-completion/completions/rclone
+ install -Dm644 rclone.zsh_completion "$pkgdir"/usr/share/zsh/site-functions/_rclone
+
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
- install -Dm644 rclone.1 "$pkgdir/usr/share/man/man1/rclone.1"
- install -d "$pkgdir/usr/share/doc/$pkgname"
- install -t "$pkgdir/usr/share/doc/$pkgname" -m644 MANUAL.html MANUAL.txt
+ install -Dm644 rclone.1 "$pkgdir"/usr/share/man/man1/rclone.1
+ install -d "$pkgdir"/usr/share/doc/$pkgname
+ install -t "$pkgdir"/usr/share/doc/$pkgname -m644 MANUAL.html MANUAL.txt
}