summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-05-01 01:05:07 +0200
committerFabioLolix2018-05-01 01:05:07 +0200
commitb16d0fe94d6c9d15931db14473d7785859400cc7 (patch)
tree2bc40b3bfdead8af43fc500a2d0a1f972d886dc0
parentf3deb4e70da992a0e828c4ca7463fc56d1a434c8 (diff)
downloadaur-b16d0fe94d6c9d15931db14473d7785859400cc7.tar.gz
fixed build & pkgver
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD65
3 files changed, 33 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 577c7cf1c212..0e101c941abb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Wed Feb 22 13:24:16 UTC 2017
pkgbase = rclone-git
pkgdesc = Sync files to and from Google Drive, S3, Swift, Cloudfiles, Dropbox and Google Cloud Storage
- pkgver = v1.35.r131.g12aa03f
+ pkgver = 1.41.r8.g50dc5fe9
pkgrel = 1
url = http://rclone.org/
arch = i686
@@ -11,11 +9,11 @@ pkgbase = rclone-git
makedepends = git
makedepends = python2
makedepends = pandoc
- makedepends = go
+ makedepends = go-pie
depends = glibc
provides = rclone
conflicts = rclone
- source = rclone::git+https://github.com/ncw/rclone.git
+ source = rclone-git::git+https://github.com/ncw/rclone.git
sha256sums = SKIP
pkgname = rclone-git
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 1ce12f2b57bb..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,3 +0,0 @@
-src/
-pkg/
-
diff --git a/PKGBUILD b/PKGBUILD
index 861b09a4fe5b..5e7f9f75debd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,56 @@
-# $Id: PKGBUILD 204582 2017-01-03 04:27:30Z felixonmars $
-# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Maintainer: Saren Arterius <saren at wtako dot com>
+# Contributor: Felix Yan
-_pkgname=rclone
-pkgname="${_pkgname}-git"
-pkgver=v1.35.r131.g12aa03f
+pkgname=rclone-git
+pkgver=1.41.r8.g50dc5fe9
pkgrel=1
pkgdesc="Sync files to and from Google Drive, S3, Swift, Cloudfiles, Dropbox and Google Cloud Storage"
arch=('i686' 'x86_64')
url="http://rclone.org/"
license=('MIT')
depends=('glibc')
-makedepends=('git' 'python2' 'pandoc' 'go')
-source=("${_pkgname}::git+https://github.com/ncw/${_pkgname}.git")
-conflicts=("${_pkgname}")
-provides=("${_pkgname}")
+makedepends=('git' 'python2' 'pandoc' 'go-pie')
+source=("${pkgname}::git+https://github.com/ncw/rclone.git")
+conflicts=('rclone')
+provides=('rclone')
sha256sums=('SKIP')
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
prepare() {
- cd ${_pkgname}
+ cd "${pkgname}"
- sed -i "1s/python$/&2/" bin/make_manual.py
+ sed -i "1s/python$/&2/" bin/make_manual.py
- mkdir -p .gopath/src/github.com/ncw
- ln -sf "$PWD" .gopath/src/github.com/ncw/${_pkgname}
- export GOPATH="$PWD/.gopath"
+ mkdir -p .gopath/src/github.com/ncw
+ ln -sf "$PWD" .gopath/src/github.com/ncw/rclone
+ export GOPATH="$PWD/.gopath"
- go get github.com/go-ini/ini github.com/jmespath/go-jmespath
- go get github.com/ncw/${_pkgname}
-}
-
-pkgver() {
- cd "${_pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ go get github.com/ncw/rclone
}
build() {
- cd ${_pkgname}
+ cd "${pkgname}/.gopath/src/github.com/ncw/rclone"
- go build # -gccgoflags "$CFLAGS $LDFLAGS"
- PATH="$GOPATH/bin:$PATH" make doc
+ PATH="$GOPATH/bin:$PATH" make TAG=v$pkgver rclone doc
}
check() {
- cd ${_pkgname}
-
- mkdir -p "$GOPATH/src/_/build/${_pkgname}/src"
- ln -s "$srcdir/${_pkgname}" "$GOPATH/src/_/build/${_pkgname}/src/${_pkgname}"
- make test || warning "Tests failed"
+ cd "${pkgname}/.gopath/src/github.com/ncw/rclone"
+ make TAG=v$pkgver test || warning "Tests failed"
}
package() {
- cd ${_pkgname}
- make DESTDIR="$pkgdir" install
+ cd "${pkgname}/.gopath/src/github.com/ncw/rclone"
+ make TAG=v$pkgver DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
- install -Dm644 ${_pkgname}.1 "$pkgdir/usr/share/man/man1/${_pkgname}.1"
- install -d "$pkgdir/usr/share/doc/$pkgname"
- install -t "$pkgdir/usr/share/doc/$pkgname" -m644 MANUAL.html MANUAL.txt
+ install -Dm644 rclone.1 "$pkgdir/usr/share/man/man1/rclone.1"
+ install -d "$pkgdir/usr/share/doc/$pkgname"
+ install -t "$pkgdir/usr/share/doc/$pkgname" -m644 MANUAL.html MANUAL.txt
}