summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Falk2017-02-22 14:26:35 +0100
committerMax Falk2017-02-22 14:26:35 +0100
commitf3deb4e70da992a0e828c4ca7463fc56d1a434c8 (patch)
treecb0bd04e08e0ab9e8155eee1ad5aa0b6157ca1d4
downloadaur-f3deb4e70da992a0e828c4ca7463fc56d1a434c8.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD61
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..577c7cf1c212
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed Feb 22 13:24:16 UTC 2017
+pkgbase = rclone-git
+ pkgdesc = Sync files to and from Google Drive, S3, Swift, Cloudfiles, Dropbox and Google Cloud Storage
+ pkgver = v1.35.r131.g12aa03f
+ pkgrel = 1
+ url = http://rclone.org/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = python2
+ makedepends = pandoc
+ makedepends = go
+ depends = glibc
+ provides = rclone
+ conflicts = rclone
+ source = rclone::git+https://github.com/ncw/rclone.git
+ sha256sums = SKIP
+
+pkgname = rclone-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1ce12f2b57bb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..861b09a4fe5b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# $Id: PKGBUILD 204582 2017-01-03 04:27:30Z felixonmars $
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+_pkgname=rclone
+pkgname="${_pkgname}-git"
+pkgver=v1.35.r131.g12aa03f
+pkgrel=1
+pkgdesc="Sync files to and from Google Drive, S3, Swift, Cloudfiles, Dropbox and Google Cloud Storage"
+arch=('i686' 'x86_64')
+url="http://rclone.org/"
+license=('MIT')
+depends=('glibc')
+makedepends=('git' 'python2' 'pandoc' 'go')
+source=("${_pkgname}::git+https://github.com/ncw/${_pkgname}.git")
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${_pkgname}
+
+ sed -i "1s/python$/&2/" bin/make_manual.py
+
+ mkdir -p .gopath/src/github.com/ncw
+ ln -sf "$PWD" .gopath/src/github.com/ncw/${_pkgname}
+ export GOPATH="$PWD/.gopath"
+
+ go get github.com/go-ini/ini github.com/jmespath/go-jmespath
+ go get github.com/ncw/${_pkgname}
+}
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd ${_pkgname}
+
+ go build # -gccgoflags "$CFLAGS $LDFLAGS"
+ PATH="$GOPATH/bin:$PATH" make doc
+}
+
+check() {
+ cd ${_pkgname}
+
+ mkdir -p "$GOPATH/src/_/build/${_pkgname}/src"
+ ln -s "$srcdir/${_pkgname}" "$GOPATH/src/_/build/${_pkgname}/src/${_pkgname}"
+ make test || warning "Tests failed"
+}
+
+package() {
+ cd ${_pkgname}
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+
+ install -Dm644 ${_pkgname}.1 "$pkgdir/usr/share/man/man1/${_pkgname}.1"
+ install -d "$pkgdir/usr/share/doc/$pkgname"
+ install -t "$pkgdir/usr/share/doc/$pkgname" -m644 MANUAL.html MANUAL.txt
+}