summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2021-03-16 10:36:41 -0700
committerMike Swanson2021-03-16 10:36:41 -0700
commit4c356c04ce4b5eaa9a1842cd51d1efeb422b0790 (patch)
treef7a487dd074a87e970bb916e06342da95feefe96
parent6f08b7642bab281d77da389928279d7f88dc692b (diff)
downloadaur-4c356c04ce4b5eaa9a1842cd51d1efeb422b0790.tar.gz
Update to 1.1
Also include the two post-1.1 commits as patches.
-rw-r--r--.SRCINFO15
-rw-r--r--0001-Fix-fatal-typo.patch25
-rw-r--r--0002-Attempyt-fix-for-GitLab-issue-1.patch52
-rw-r--r--PKGBUILD37
4 files changed, 114 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index adbe9160202c..43cf18cb7fa5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,19 @@
pkgbase = rcs-fast-import
pkgdesc = Unpack a Git fast-import stream into an RCS file tree
- pkgver = 1.0
- pkgrel = 2
+ pkgver = 1.1
+ pkgrel = 1
url = http://www.catb.org/esr/rcs-fast-import/
arch = any
license = BSD
- depends = python2
+ makedepends = xmlto
+ depends = python
depends = rcs
- source = http://www.catb.org/esr/rcs-fast-import/rcs-fast-import-1.0.tar.gz
- sha256sums = 57bb2771ecc534f71e479af0cbcb4a9b4b75d106b3fe7259191ead8c261f0604
+ source = https://gitlab.com/esr/rcs-fast-import/-/archive/1.1/rcs-fast-import-1.1.tar.gz
+ source = 0001-Fix-fatal-typo.patch
+ source = 0002-Attempyt-fix-for-GitLab-issue-1.patch
+ b2sums = 7b1fd0135337d315eb52e7316d2ff2a8ba761f098abbc647ffcbff8e837d0e1811c46df31684b8ee60e2ba91f89f74b18c76e52b284ef38a649b020f151b04f6
+ b2sums = 7f8d9f83815d606225d461259ecc76d57ac4dcc7753e05360076cdb5d4df11b86699830ff0a7e706de096c5e7a6e3616817540776caadc5dead6a985e7d00cda
+ b2sums = ee951836851663357883c40884cd434a047b3e7661da9eed5acf863539b607ef6e240d2934979830a90c0be11bf10138308e18ae564c2757fe528183d4441af6
pkgname = rcs-fast-import
diff --git a/0001-Fix-fatal-typo.patch b/0001-Fix-fatal-typo.patch
new file mode 100644
index 000000000000..573e95afdd82
--- /dev/null
+++ b/0001-Fix-fatal-typo.patch
@@ -0,0 +1,25 @@
+From d66912ab46c31129d1ec500e7c343369bbf4267b Mon Sep 17 00:00:00 2001
+From: "Eric S. Raymond" <esr@thyrsus.com>
+Date: Wed, 27 May 2020 08:02:31 -0400
+Subject: [PATCH 1/2] Fix fatal typo.
+
+---
+ rcs-fast-import | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/rcs-fast-import b/rcs-fast-import
+index cf94d36..1d7d064 100755
+--- a/rcs-fast-import
++++ b/rcs-fast-import
+@@ -544,7 +544,7 @@ def sanecheck(_event, path, mode):
+ raise FatalException("unknown mode %s on %s" % (mode, path))
+
+ def complain(msg):
+- sys.stderr.wrie("rcs-fast-import: " + msg + "\n")
++ sys.stderr.write("rcs-fast-import: " + msg + "\n")
+
+ def announce(msg):
+ print("rcs-fast-import:", msg)
+--
+2.30.2
+
diff --git a/0002-Attempyt-fix-for-GitLab-issue-1.patch b/0002-Attempyt-fix-for-GitLab-issue-1.patch
new file mode 100644
index 000000000000..1cc1da794ae0
--- /dev/null
+++ b/0002-Attempyt-fix-for-GitLab-issue-1.patch
@@ -0,0 +1,52 @@
+From 38251ef14940585f77ce5de25b33bbfe75e9cbb2 Mon Sep 17 00:00:00 2001
+From: "Eric S. Raymond" <esr@thyrsus.com>
+Date: Wed, 27 May 2020 08:23:35 -0400
+Subject: [PATCH 2/2] Attempyt fix for GitLab issue #1.
+
+---
+ Makefile | 2 +-
+ rcs-fast-import | 8 +++++++-
+ 2 files changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 05dbb87..afec305 100644
+--- a/Makefile
++++ b/Makefile
+@@ -30,7 +30,7 @@ rcs-fast-import-$(VERS).tar.gz: $(SOURCES) rcs-fast-import.1
+ PYLINTOPTS = --rcfile=/dev/null --reports=n \
+ --msg-template="{path}:{line}: [{msg_id}({symbol}), {obj}] {msg}" \
+ --dummy-variables-rgx='^_'
+-SUPPRESSIONS = "C0103,C0111,C0301,C0325,C0410,C0323,C0330,C1001,R0902,R0903,R0912,R0913,R0914,R0915,R1702,W0110,W0141,W0333,W0142,W0621,E1101"
++SUPPRESSIONS = "C0103,C0111,C0301,C0325,C0410,C0323,C0330,C1001,R0902,R0903,R0912,R0913,R0914,R0915,R1702,R1720,R1723,W0110,W0141,W0333,W0142,W0621,E1101"
+ pylint:
+ @pylint $(PYLINTOPTS) --disable=$(SUPPRESSIONS) rcs-fast-import
+
+diff --git a/rcs-fast-import b/rcs-fast-import
+index 1d7d064..1998583 100755
+--- a/rcs-fast-import
++++ b/rcs-fast-import
+@@ -773,7 +773,7 @@ class RCS(Generic):
+ def postcommit(self, event):
+ "Save annotated tags for round-tripping."
+ for tag in event.taglist:
+- with file("ANNOTATED-TAGS", "w") as fp:
++ with open("ANNOTATED-TAGS", "w") as fp:
+ fp.write(tag.email_out())
+ do_or_die("ci -l -m'Annotated tag %s' -d'%s' ANNOTATED-TAGS,v"
+ % (tag.name, tag.tagger.date.rfc822()))
+@@ -805,6 +805,12 @@ if __name__ == '__main__':
+ print("rcs-fast-import version %s" % version)
+ raise SystemExit(0)
+
++ # Nasty black magic. Replace stdin with a version of itself that uses an encoding
++ # that never aggregates bytes on input into multibyte code points. Without this
++ # fix, the attempt to read blob fdata failrs because the fp.read() skips code
++ # points, not bytes. Alas that Python 3 Unicode handling is such a botch!
++ sys.stdin = io.TextIOWrapper(sys.stdin.buffer, encoding='latin-1', newline="\n")
++
+ vcs = RCS()
+ vcs.roundtrip = roundtrip
+ try:
+--
+2.30.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 4c5f4ee59b87..357894659630 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,43 @@
# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
pkgname=rcs-fast-import
-pkgver=1.0
-pkgrel=2
+pkgver=1.1
+pkgrel=1
pkgdesc="Unpack a Git fast-import stream into an RCS file tree"
arch=('any')
url="http://www.catb.org/esr/$pkgname/"
license=('BSD')
-depends=('python2' 'rcs')
-source=("$url$pkgname-$pkgver.tar.gz")
-sha256sums=('57bb2771ecc534f71e479af0cbcb4a9b4b75d106b3fe7259191ead8c261f0604')
+makedepends=('xmlto')
+depends=('python' 'rcs')
+source=("https://gitlab.com/esr/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+ 0001-Fix-fatal-typo.patch
+ 0002-Attempyt-fix-for-GitLab-issue-1.patch)
+b2sums=('7b1fd0135337d315eb52e7316d2ff2a8ba761f098abbc647ffcbff8e837d0e1811c46df31684b8ee60e2ba91f89f74b18c76e52b284ef38a649b020f151b04f6'
+ '7f8d9f83815d606225d461259ecc76d57ac4dcc7753e05360076cdb5d4df11b86699830ff0a7e706de096c5e7a6e3616817540776caadc5dead6a985e7d00cda'
+ 'ee951836851663357883c40884cd434a047b3e7661da9eed5acf863539b607ef6e240d2934979830a90c0be11bf10138308e18ae564c2757fe528183d4441af6')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
- sed -i -e '1s/python/python2/' rcs-fast-import
+
+ for patch in ../*.patch; do
+ if [ ! -f "$patch" ]; then
+ break;
+ else
+ patch -p1 -i "$patch"
+ fi
+ done
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make
}
package() {
cd "$srcdir/$pkgname-$pkgver"
- install -d "$pkgdir/usr/bin"
- install -d "$pkgdir/usr/share/man/man1"
- install "$pkgname" "$pkgdir/usr/bin"
- install -m644 "$pkgname.1" "$pkgdir/usr/share/man/man1"
+
+ install -D "$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm644 "$pkgname.1" -t "$pkgdir/usr/share/man/man1"
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}