summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRadek Podgorny2019-01-10 10:32:20 +0100
committerRadek Podgorny2019-01-10 10:32:20 +0100
commit65a839f3d6226add8ed2db26a33ad001fd1dff49 (patch)
tree54088ff255485ddd2d23db949b1a7f41080e3d9a
downloadaur-65a839f3d6226add8ed2db26a33ad001fd1dff49.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7a5f4998567
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = rcswitch-pi-git
+ pkgdesc = rapberry pi library for rc controlled outlets
+ pkgver = r10.1c4e20f
+ pkgrel = 1
+ url = https://github.com/rpodgorny/rcswitch-pi
+ arch = armv6h
+ license = GPL
+ depends = wiringpi
+ provides = rcswitch-pi
+ conflicts = rcswitch-pi
+ source = git+https://github.com/rpodgorny/rcswitch-pi.git
+ md5sums = SKIP
+
+pkgname = rcswitch-pi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..877f072a9b20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Radek Podgorny <radek@podgorny.cz>
+pkgname=rcswitch-pi-git
+pkgver=r10.1c4e20f
+pkgrel=1
+pkgdesc="rapberry pi library for rc controlled outlets"
+arch=('armv6h')
+url="https://github.com/rpodgorny/rcswitch-pi"
+license=('GPL')
+depends=('wiringpi')
+provides=('rcswitch-pi')
+conflicts=('rcswitch-pi')
+source=('git+https://github.com/rpodgorny/rcswitch-pi.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/rcswitch-pi"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/rcswitch-pi"
+ #./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/rcswitch-pi"
+ make DESTDIR="$pkgdir/" install
+}