summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Maguire2022-07-01 07:36:29 +1000
committerMatt Maguire2022-07-01 07:36:29 +1000
commit8ebe3f55f5d0c85cd5f78140d4901d5a69ad3157 (patch)
treec9bf2e938014bc84b52a6ed16fef25bfd8b1d2b6
downloadaur-8ebe3f55f5d0c85cd5f78140d4901d5a69ad3157.tar.gz
Initial commit
-rw-r--r--.SRCINFO48
-rw-r--r--PKGBUILD68
-rw-r--r--darktable.install23
3 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72c8984eb29f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,48 @@
+pkgbase = rdarktable-git
+ pkgdesc = A virtual lighttable and darkroom for photographers, based on the "rationalised" R&Darktable fork from Aurélien Pierre.
+ pkgver = 3.9.0.r1643.g60bbf83ac
+ pkgrel = 1
+ url = https://github.com/aurelienpierre/R-Darktable/blob/master/README.md
+ install = darktable.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = intltool
+ makedepends = desktop-file-utils
+ makedepends = llvm
+ makedepends = clang
+ makedepends = python-jsonschema
+ makedepends = libwebp
+ depends = pugixml
+ depends = libjpeg-turbo
+ depends = colord-gtk
+ depends = libgphoto2
+ depends = openexr
+ depends = lensfun
+ depends = iso-codes
+ depends = zlib
+ depends = exiv2
+ depends = flickcurl
+ depends = openjpeg2
+ depends = graphicsmagick
+ depends = lua53
+ depends = osm-gps-map
+ depends = libsecret
+ depends = openmp
+ depends = gmic
+ depends = libavif
+ optdepends = dcraw: base curve script
+ optdepends = perl-image-exiftool: base curve script
+ optdepends = imagemagick: base curve and noise profile scripts
+ optdepends = ghostscript: noise profile script
+ optdepends = gnuplot: noise profile script
+ provides = darktable
+ conflicts = darktable
+ options = !emptydirs
+ options = !libtool
+ source = git+https://github.com/aurelienpierre/R-Darktable.git
+ md5sums = SKIP
+
+pkgname = rdarktable-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18a3d4b3a14b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Matt Maguire <matthew.maguire at gmail dot com>
+# Contributor: Marco44 <cousinmarc at gmail dot com>
+# Contributor: Sarkasper <echo a2FzcGVyLm1lbnRlbkBnbXguY29tCg== | base64 -d>
+# Contributor: Christian Himpel <chressie at gmail dot com>
+# Contributor: Johannes Hanika <hanatos at gmail dot com>
+# Contributor: Kevin Brubeck Unhammer <unhammer at member dot fsf dot org>
+# Contributor: orbisvicis <orbisvicis at gmail dot com>
+pkgname=rdarktable-git
+_gitname=R-Darktable
+pkgver=3.9.0.r1643.g60bbf83ac
+pkgrel=1
+pkgdesc="A virtual lighttable and darkroom for photographers, based on the \"rationalised\" R&Darktable fork from Aurélien Pierre."
+arch=('i686' 'x86_64')
+url=https://github.com/aurelienpierre/R-Darktable/blob/master/README.md
+license=('GPL3')
+depends=(pugixml libjpeg-turbo colord-gtk libgphoto2 openexr lensfun iso-codes zlib
+ exiv2 flickcurl openjpeg2 graphicsmagick lua53 osm-gps-map libsecret openmp
+ gmic libavif)
+optdepends=('dcraw: base curve script'
+ 'perl-image-exiftool: base curve script'
+ 'imagemagick: base curve and noise profile scripts'
+ 'ghostscript: noise profile script'
+ 'gnuplot: noise profile script')
+makedepends=(git cmake intltool desktop-file-utils llvm clang python-jsonschema libwebp)
+conflicts=(darktable)
+provides=(darktable)
+install=darktable.install
+options=(!emptydirs !libtool)
+source=('git+https://github.com/aurelienpierre/R-Darktable.git'
+)
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ git describe --long --tags | sed 's/^release-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $_gitname
+ git config submodule.src/tests/integration.update none
+ git submodule update --init --recursive
+}
+
+build() {
+ cd $_gitname
+ [[ ! -d build ]] && mkdir -p build
+ cmake -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DCMAKE_INSTALL_LIBEXECDIR=/usr/lib \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBINARY_PACKAGE_BUILD=1 \
+ -DBUILD_USERMANUAL=False \
+ -DUSE_LIBSECRET=ON \
+ -DUSE_LUA=ON \
+ -DUSE_COLORD=ON \
+ -DBUILD_CURVE_TOOLS=ON \
+ -DBUILD_NOISE_TOOLS=ON \
+ -DRAWSPEED_ENABLE_LTO=ON
+ make -j`grep -c '^processor' /proc/cpuinfo` -C build
+
+}
+
+package() {
+ cd $_gitname
+ make -C build DESTDIR=$pkgdir install
+ ln -s darktable/libdarktable.so "${pkgdir}"/usr/lib/libdarktable.so
+}
diff --git a/darktable.install b/darktable.install
new file mode 100644
index 000000000000..9fd6af2938f3
--- /dev/null
+++ b/darktable.install
@@ -0,0 +1,23 @@
+pkgname=darktable
+
+post_install() {
+# usr/sbin/gconfpkg --install ${pkgname}
+ [ -x `which update-desktop-database` ] && update-desktop-database -q
+}
+
+pre_upgrade() {
+ pre_remove
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+# usr/sbin/gconfpkg --uninstall ${pkgname}
+ true
+}
+
+post_remove() {
+ [ -x `which update-desktop-database` ] && update-desktop-database -q
+}