summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph S2017-12-31 10:51:18 +0100
committerChristoph Schober2017-12-31 10:51:18 +0100
commit0adc502f40c3fe5466351899ac8fdd6125902c38 (patch)
treeb05058e79af6c2f8f1c7e3d637d653558590e907
parentec09f586a917fe62533129aae207975f6bd848ca (diff)
downloadaur-0adc502f40c3fe5466351899ac8fdd6125902c38.tar.gz
Updated PKGBUILD and .SRCINFO for latest (stable) version of rdedup
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa4da8324a15..ec8b3558c568 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rdedup
pkgdesc = Data deduplication engine, supporting optional compression and public key encryption
- pkgver = 1.0.2
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/dpc/rdedup
arch = i686
@@ -8,8 +8,8 @@ pkgbase = rdedup
license = MPL
makedepends = cargo
depends = libsodium
- source = https://github.com/dpc/rdedup/archive/v1.0.2/rdedup-1.0.2.tar.gz
- sha256sums = 05ffcc2b155137d3ffa72b90253141a0aceb62e582d85a5be3862201d3ef4498
+ source = https://github.com/dpc/rdedup/archive/v2.0.0/rdedup-v2.0.0.tar.gz
+ sha256sums = 5be893fb82a8657b4a47474c429bbb95a7bec8a27f10b96948f52b61f10bdb81
pkgname = rdedup
diff --git a/PKGBUILD b/PKGBUILD
index 2bf2facb8f9b..dce0a570b5d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Vlad M. <vlad@archlinux.net>
+# Maintainer: Christoph S. <cadberry@mailbox.org>
+# Contributor: Vlad M. <vlad@archlinux.net>
pkgname=rdedup
-pkgver=1.0.2
+pkgver=2.0.0
pkgrel=1
pkgdesc="Data deduplication engine, supporting optional compression and public key encryption"
url='https://github.com/dpc/rdedup'
@@ -9,12 +10,12 @@ depends=('libsodium')
makedepends=('cargo')
arch=('i686' 'x86_64')
license=('MPL')
-source=("$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('05ffcc2b155137d3ffa72b90253141a0aceb62e582d85a5be3862201d3ef4498')
+source=("$url/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+sha256sums=('5be893fb82a8657b4a47474c429bbb95a7bec8a27f10b96948f52b61f10bdb81')
build() {
cd "$pkgname-$pkgver"
- cargo build --release
+ RUSTFLAGS="-C target-cpu=native" cargo build --release
}
package() {