summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlad2017-06-06 11:41:29 +0300
committervlad2017-06-06 11:41:29 +0300
commitec09f586a917fe62533129aae207975f6bd848ca (patch)
tree4989bc52a9a23f1de0310b9492ba22e025ce32c0
downloadaur-ec09f586a917fe62533129aae207975f6bd848ca.tar.gz
add rdedup
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa4da8324a15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = rdedup
+ pkgdesc = Data deduplication engine, supporting optional compression and public key encryption
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/dpc/rdedup
+ arch = i686
+ arch = x86_64
+ license = MPL
+ makedepends = cargo
+ depends = libsodium
+ source = https://github.com/dpc/rdedup/archive/v1.0.2/rdedup-1.0.2.tar.gz
+ sha256sums = 05ffcc2b155137d3ffa72b90253141a0aceb62e582d85a5be3862201d3ef4498
+
+pkgname = rdedup
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2bf2facb8f9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Vlad M. <vlad@archlinux.net>
+
+pkgname=rdedup
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Data deduplication engine, supporting optional compression and public key encryption"
+url='https://github.com/dpc/rdedup'
+depends=('libsodium')
+makedepends=('cargo')
+arch=('i686' 'x86_64')
+license=('MPL')
+source=("$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('05ffcc2b155137d3ffa72b90253141a0aceb62e582d85a5be3862201d3ef4498')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}