summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Sovetkin2015-06-08 11:16:51 +0200
committerEugene Sovetkin2015-06-08 11:16:51 +0200
commit6987992c02bf718789a45ebd9179d98cb249fa1d (patch)
treefc2b2c8bb486625048980a705b78c5f813c2db64
downloadaur-6987992c02bf718789a45ebd9179d98cb249fa1d.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
-rw-r--r--rdictcc-git.install6
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4428f873b330
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = rdictcc-git
+ pkgdesc = A dictionary / word translator written in Ruby. It uses the dictionaries you can fetch from http://www.dict.cc. RDictCc has a tight integration into Emacs.
+ pkgver = 20120324
+ pkgrel = 1
+ url = https://github.com/tsdh/rdictcc
+ install = rdictcc-git.install
+ arch = any
+ license = GPL3
+ depends = ruby
+ depends = gdbm
+ provides = rdictcc
+ conflicts = rdictcc
+
+pkgname = rdictcc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f865767dbd87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Dennis Felsing <defelsing+aur@gmail.com>, Evgenii Sovetkin <e.sovetkin@gmail.com>
+
+pkgname=rdictcc-git
+pkgver=20120324
+pkgrel=1
+pkgdesc="A dictionary / word translator written in Ruby. It uses the dictionaries you can fetch from http://www.dict.cc. RDictCc has a tight integration into Emacs."
+arch=('any')
+url="https://github.com/tsdh/rdictcc"
+license=('GPL3')
+depends=('ruby' 'gdbm')
+install=rdictcc-git.install
+provides=('rdictcc')
+conflicts=('rdictcc')
+
+_gitroot=git://github.com/tsdh/rdictcc.git
+_gitname=rdictcc
+
+build() {
+ cd "${srcdir}"
+ msg "Connecting to GIT server...."
+
+ if [ -d ${_gitname} ] ; then
+ cd ${_gitname} && git pull origin
+ msg "The local files are updated."
+ else
+ git clone ${_gitroot} ${_gitname}
+ cd "${_gitname}"
+ fi
+
+ msg "GIT checkout done or server timeout"
+
+ sed -i "s#-<>]/, ' ').strip.split do |w|#<>-]/, ' ').strip.split do#" rdictcc.rb
+ sed -i 's#rdictcc.rb#rdictcc#g' rdictcc.rb
+ sed -i 's#/usr/local/bin/rdictcc.rb#/usr/bin/rdictcc#' rdictcc.el
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ install -Dm755 rdictcc.rb "$pkgdir/usr/bin/rdictcc"
+ install -Dm644 rdictcc.el "$pkgdir/usr/share/emacs/site-lisp/rdictcc.el"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/rdictcc/COPYING"
+}
diff --git a/rdictcc-git.install b/rdictcc-git.install
new file mode 100644
index 000000000000..8e09b6fc2ab9
--- /dev/null
+++ b/rdictcc-git.install
@@ -0,0 +1,6 @@
+post_install() {
+ echo "To use rdictcc you need a copy of a translation database of dict.cc"
+ echo "You can download them in UTF-8 from http://www1.dict.cc/translation_file_request.php"
+ echo "Import a database by calling"
+ echo " rdictcc --import dict-file.txt"
+}