summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxeruf2022-02-07 09:50:56 +0100
committerxeruf2022-02-07 09:50:56 +0100
commitc5b241de1b3b0c6c891256cfd8a448dc41261ca1 (patch)
tree611cb68c49fced91df7d3f2a0f79c8fb2431d8b0
parentcd140ef1a9279c41158746a8f6671a9e5f6e8101 (diff)
downloadaur-c5b241de1b3b0c6c891256cfd8a448dc41261ca1.tar.gz
Move to sourcehut and update description and maintainership
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b4f92bb85c4..8073f4b7e52f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
-# Generated by mksrcinfo v8
-# Sat Jul 22 22:00:03 UTC 2017
pkgbase = rdictcc-git
- pkgdesc = A dictionary / word translator written in Ruby. It uses the dictionaries you can fetch from http://www.dict.cc. RDictCc has a tight integration into Emacs.
- pkgver = r36.43192fc
+ pkgdesc = A Ruby translator using dictionary files from http://www.dict.cc, with tight Emacs integration
+ pkgver = r44.52f6b4b
pkgrel = 1
- url = https://github.com/tsdh/rdictcc
+ url = https://git.sr.ht/~tsdh/rdictcc
arch = any
license = GPL3
makedepends = git
depends = ruby
depends = gdbm
- source = git+git://github.com/tsdh/rdictcc.git
- sha256sums = SKIP
+ source = git+https://git.sr.ht/~tsdh/rdictcc
+ sha512sums = SKIP
pkgname = rdictcc-git
-
diff --git a/PKGBUILD b/PKGBUILD
index cbbd41593aa7..eaa9576f7cb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
-# Maintainer: Jenya Sovetkin <e dot sovetkin at gmail dot com>
-pkgname=rdictcc-git
-pkgver=r36.43192fc
+# Maintainer: xeruf <27jf at pm dot me>
+
+_pkgname=rdictcc
+pkgname=${_pkgname}-git
+pkgver=r44.52f6b4b
pkgrel=1
-pkgdesc="A dictionary / word translator written in Ruby. It uses the dictionaries you can fetch from http://www.dict.cc. RDictCc has a tight integration into Emacs."
+pkgdesc="A Ruby translator using dictionary files from http://www.dict.cc, with tight Emacs integration"
arch=('any')
-url="https://github.com/tsdh/rdictcc"
+url="https://git.sr.ht/~tsdh/${_pkgname}"
license=('GPL3')
depends=('ruby' 'gdbm')
makedepends=('git')
-sha256sums=('SKIP')
-source=('git+git://github.com/tsdh/rdictcc.git')
-
-_gitroot=git://github.com/tsdh/rdictcc.git
-_gitname=rdictcc
+source=("git+${url}")
+sha512sums=(SKIP)
pkgver() {
- cd "${srcdir}/${_gitname}"
+ cd "${srcdir}/${_pkgname}"
# Get the version number.
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "${srcdir}/${_gitname}"
+ cd "${srcdir}/${_pkgname}"
sed -i "s#-<>]/, ' ').strip.split do |w|#<>-]/, ' ').strip.split do#" rdictcc.rb
sed -i 's#rdictcc.rb#rdictcc#g' rdictcc.rb