summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Honeyman2015-06-09 19:10:18 +0100
committerSteven Honeyman2015-06-09 19:10:18 +0100
commitfa8610c5257de8928e67d647b8a3263801b2da58 (patch)
tree930df9d9661e1cf4a7c68840430986f007c4cc19
downloadaur-fa8610c5257de8928e67d647b8a3263801b2da58.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
3 files changed, 63 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..a40884d587d6
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = rdis-git
+ pkgdesc = A graphic binary analysis tool. Check rdis-lua for some scripts that improve its functionality.
+ pkgver = 20140126
+ pkgrel = 1
+ url = https://github.com/endeav0r/rdis
+ arch = x86_64
+ license = GPL3
+ depends = gtk3
+ depends = luajit
+ depends = jansson
+ depends = udis86
+ source = git+http://github.com/endeav0r/rdis.git
+
+pkgname = rdis-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a4683a37b6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = rdis-git
+ pkgdesc = A graphic binary analysis tool. Check rdis-lua for some scripts that improve its functionality.
+ pkgver = 20140126
+ pkgrel = 1
+ url = https://github.com/endeav0r/rdis
+ arch = x86_64
+ license = GPL3
+ depends = gtk3
+ depends = luajit
+ depends = jansson
+ depends = udis86
+ source = git+http://github.com/endeav0r/rdis.git
+ md5sums = SKIP
+
+pkgname = rdis-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c7ecaab2175
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=rdis-git
+pkgrel=1
+pkgver=20140126
+pkgdesc="A graphic binary analysis tool. Check rdis-lua for some scripts that improve its functionality. "
+arch=(x86_64)
+url="https://github.com/endeav0r/rdis"
+license=('GPL3')
+depends=('gtk3' 'luajit' 'jansson' 'udis86')
+source=("git+http://github.com/endeav0r/rdis.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/rdis"
+ git log -1 --format="%cd" --date=short | sed 's|-||g'
+}
+
+prepare() {
+ cd "$srcdir/rdis"
+ sed -i 's,/usr/bin,$(DESTDIR)&,g' Makefile
+ find . -name "Makefile" -exec sed -i 's/-Werror//g' '{}' \;
+}
+
+build() {
+ cd "$srcdir/rdis"
+ make
+}
+
+package() {
+ cd "$srcdir/rdis"
+ install -dm0755 "${pkgdir}"/usr/bin # badly written Makefile!
+ make DESTDIR="${pkgdir}" install
+}