summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVedran Miletić2023-05-23 18:38:11 +0200
committerVedran Miletić2023-05-23 18:38:11 +0200
commit2ff58dad68fbca114ac764c8d2a730f9bf66d189 (patch)
treea6783453d24b6ff274908dc7befe3f5711d2bd1e
parent70c188a486bd4338a5089992430e99e1b7561b2b (diff)
downloadaur-2ff58dad68fbca114ac764c8d2a730f9bf66d189.tar.gz
Updated version to 2023_03_1 with a patch for GCC 13.1
-rw-r--r--0001-Added-cstdint-include-6338.patch25
-rw-r--r--PKGBUILD18
2 files changed, 38 insertions, 5 deletions
diff --git a/0001-Added-cstdint-include-6338.patch b/0001-Added-cstdint-include-6338.patch
new file mode 100644
index 000000000000..481d081ef440
--- /dev/null
+++ b/0001-Added-cstdint-include-6338.patch
@@ -0,0 +1,25 @@
+From f4e929a440d0fffe57be63f20cb0088763ef4c62 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Vedran=20Mileti=C4=87?= <vedran@miletic.net>
+Date: Wed, 10 May 2023 05:58:54 +0200
+Subject: [PATCH 01/14] Added cstdint include (#6338)
+
+Required for uint64_t, fixes compile error
+---
+ Code/RDGeneral/RDLog.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Code/RDGeneral/RDLog.h b/Code/RDGeneral/RDLog.h
+index 83b04d29a..89ef38cce 100644
+--- a/Code/RDGeneral/RDLog.h
++++ b/Code/RDGeneral/RDLog.h
+@@ -20,6 +20,7 @@
+ #include <iostream>
+ #include <fstream>
+ #include <vector>
++#include <cstdint>
+
+ namespace boost {
+ namespace logging {
+--
+2.40.1
+
diff --git a/PKGBUILD b/PKGBUILD
index f50bb48f3e08..fa2d4e0410a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,30 @@
-# Old Maintainer: Samo Turk <samo.turk@gmail.com>
# Maintainer: Hector Mtz-Seara <hseara # gmail.com>
+# Maintainer: Vedran Miletic <vedran AT miletic DOT net>
+# Contributor: Samo Turk <samo.turk@gmail.com>
pkgname=rdkit
-pkgver=2022_09_3
-pkgrel=2
+pkgver=2023_03_1
+pkgrel=1
pkgdesc="RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python."
arch=("i686" "x86_64" "armv7h")
url="http://rdkit.org/"
license=('BSD')
depends=(python python-numpy python-cairocffi python-pillow boost boost-libs sqlite cairo eigen)
makedepends=('cmake>=3.1')
-source=("https://github.com/rdkit/rdkit/archive/Release_${pkgver}.tar.gz")
-sha256sums=('188239f741842ce433b371e94cdd9e4d93955b332b9ffd5a70db2884270e261b')
+source=(
+ "https://github.com/rdkit/rdkit/archive/Release_${pkgver}.tar.gz"
+ '0001-Added-cstdint-include-6338.patch'
+)
+sha256sums=(
+ 'db346afbd0ba52c843926a2a62f8a38c7b774ffab37eaf382d789a824f21996c'
+ '2dfa6ca2859bbedf2d148a946b6d6f1ce0aaf012b08c35e81f846cc3f1b950e9'
+)
conflicts=('rdkit-python2' 'rdkit-git')
provides=(rdkit)
build() {
cd ${srcdir}/${pkgname}-Release_${pkgver}
+ patch -p1 -i ${srcdir}/0001-Added-cstdint-include-6338.patch
mkdir -p build
cd build