summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsamoturk2015-06-22 11:26:56 +0200
committersamoturk2015-06-22 11:26:56 +0200
commit3070e0dd02597aaace9e3cdade8c3a4256e6d887 (patch)
treedbc4ad9db2b6e3e8e49ed9ff51852eae5e3a9a3f
downloadaur-3070e0dd02597aaace9e3cdade8c3a4256e6d887.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73e3afd467ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = rdkit
+ pkgdesc = RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python.
+ pkgver = 2015_03_1
+ pkgrel = 1
+ url = http://rdkit.org/
+ arch = i686
+ arch = x86_64
+ license = New BSD License
+ depends = bison
+ depends = boost
+ depends = boost-libs
+ depends = cmake
+ depends = flex
+ depends = python2
+ depends = python2-numpy
+ depends = sqlite3
+ provides = rdkit
+ source = https://github.com/rdkit/rdkit/archive/Release_2015_03_1.tar.gz
+ md5sums = a6e5e90eb3ccafde2715b2c89bf1019b
+
+pkgname = rdkit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0db7243e0cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Samo Turk <samo.turk@gmail.com>
+pkgname=rdkit
+_pkgname=RDKit
+pkgver=2015_03_1
+pkgrel=1
+pkgdesc="RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python."
+arch=("i686" "x86_64")
+url="http://rdkit.org/"
+license=('New BSD License')
+depends=( 'bison' 'boost' 'boost-libs' 'cmake' 'flex' 'python2' 'python2-numpy' 'sqlite3' )
+source=(https://github.com/rdkit/rdkit/archive/Release_${pkgver}.tar.gz )
+md5sums=('a6e5e90eb3ccafde2715b2c89bf1019b')
+provides=('rdkit')
+
+build() {
+ cd ${srcdir}
+ mkdir build
+ cd build
+ cmake ../${pkgname}-Release_${pkgver} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DRDK_INSTALL_INTREE=0 \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DPYTHON_LIBRARY=/usr/lib/python2.7/config/libpython2.7.so \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7/ \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2
+ make
+}
+
+package() {
+ cd ${srcdir}/build
+ make DESTDIR=${pkgdir} install
+}