summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVedran Miletić2023-08-04 22:40:50 +0200
committerVedran Miletić2023-08-04 22:40:50 +0200
commitcf616d8906bbdc84d5be58f8a51125c197ae3921 (patch)
tree9ac0f26ad4d1060552f7ce8e7ffbf2c3d3acbb10
parent5c8ec6bfda442994b5ff7951baba160164c305ac (diff)
downloadaur-cf616d8906bbdc84d5be58f8a51125c197ae3921.tar.gz
Updated version to 2023_03_2
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Added-cstdint-include-6338.patch25
-rw-r--r--PKGBUILD7
3 files changed, 5 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ec59155dd09..91b51aaebcac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rdkit
pkgdesc = RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python.
- pkgver = 2023_03_1
+ pkgver = 2023_03_2
pkgrel = 1
url = http://rdkit.org/
arch = i686
@@ -20,9 +20,7 @@ pkgbase = rdkit
provides = rdkit
conflicts = rdkit-python2
conflicts = rdkit-git
- source = https://github.com/rdkit/rdkit/archive/Release_2023_03_1.tar.gz
- source = 0001-Added-cstdint-include-6338.patch
- sha256sums = db346afbd0ba52c843926a2a62f8a38c7b774ffab37eaf382d789a824f21996c
- sha256sums = 2dfa6ca2859bbedf2d148a946b6d6f1ce0aaf012b08c35e81f846cc3f1b950e9
+ source = https://github.com/rdkit/rdkit/archive/Release_2023_03_2.tar.gz
+ sha256sums = bb43216b075b93b767e6cbaecd5e95d087da887bcdc51afd36d940d8bd9f9819
pkgname = rdkit
diff --git a/0001-Added-cstdint-include-6338.patch b/0001-Added-cstdint-include-6338.patch
deleted file mode 100644
index 481d081ef440..000000000000
--- a/0001-Added-cstdint-include-6338.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From f4e929a440d0fffe57be63f20cb0088763ef4c62 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Vedran=20Mileti=C4=87?= <vedran@miletic.net>
-Date: Wed, 10 May 2023 05:58:54 +0200
-Subject: [PATCH 01/14] Added cstdint include (#6338)
-
-Required for uint64_t, fixes compile error
----
- Code/RDGeneral/RDLog.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/Code/RDGeneral/RDLog.h b/Code/RDGeneral/RDLog.h
-index 83b04d29a..89ef38cce 100644
---- a/Code/RDGeneral/RDLog.h
-+++ b/Code/RDGeneral/RDLog.h
-@@ -20,6 +20,7 @@
- #include <iostream>
- #include <fstream>
- #include <vector>
-+#include <cstdint>
-
- namespace boost {
- namespace logging {
---
-2.40.1
-
diff --git a/PKGBUILD b/PKGBUILD
index fa2d4e0410a2..a77a00104827 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Vedran Miletic <vedran AT miletic DOT net>
# Contributor: Samo Turk <samo.turk@gmail.com>
pkgname=rdkit
-pkgver=2023_03_1
+pkgver=2023_03_2
pkgrel=1
pkgdesc="RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python."
arch=("i686" "x86_64" "armv7h")
@@ -12,11 +12,9 @@ depends=(python python-numpy python-cairocffi python-pillow boost boost-libs sql
makedepends=('cmake>=3.1')
source=(
"https://github.com/rdkit/rdkit/archive/Release_${pkgver}.tar.gz"
- '0001-Added-cstdint-include-6338.patch'
)
sha256sums=(
- 'db346afbd0ba52c843926a2a62f8a38c7b774ffab37eaf382d789a824f21996c'
- '2dfa6ca2859bbedf2d148a946b6d6f1ce0aaf012b08c35e81f846cc3f1b950e9'
+ 'bb43216b075b93b767e6cbaecd5e95d087da887bcdc51afd36d940d8bd9f9819'
)
conflicts=('rdkit-python2' 'rdkit-git')
provides=(rdkit)
@@ -24,7 +22,6 @@ provides=(rdkit)
build() {
cd ${srcdir}/${pkgname}-Release_${pkgver}
- patch -p1 -i ${srcdir}/0001-Added-cstdint-include-6338.patch
mkdir -p build
cd build