summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAthemis2018-07-10 15:20:13 +0200
committerAthemis2018-07-10 15:20:13 +0200
commite3cf25a96f955c2ef102d77d0ddd8fdeb20199a2 (patch)
treed2ac96d20f9ed1a4b14b6619371f9c883818608a
parenta397dba87490b5dfcda954cc287f5a2095c800ef (diff)
downloadaur-e3cf25a96f955c2ef102d77d0ddd8fdeb20199a2.tar.gz
use inchi provided as AUR package
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 9 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 376f84e67afa..e5ae40f9038d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Jun 6 12:22:27 UTC 2018
+# Tue Jul 10 13:19:58 UTC 2018
pkgbase = rdkit
pkgdesc = RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python.
pkgver = 2018_03_2
- pkgrel = 1
+ pkgrel = 2
url = http://rdkit.org/
arch = i686
arch = x86_64
@@ -19,12 +19,11 @@ pkgbase = rdkit
depends = sqlite3
depends = python-cairocffi
depends = python-pillow
+ depends = inchi
conflicts = rdkit-python2
conflicts = rdkit-git
source = https://github.com/rdkit/rdkit/archive/Release_2018_03_2.tar.gz
- source = http://www.inchi-trust.org/download/105/INCHI-1-SRC.zip
sha256sums = 29eeba93e723f0f9d61e31cf0f89ec18ba942a7f9e416dbc1a92122fce08cbed
- sha256sums = 4ac311ca3a16fa75d695ec4fc711e74045c6d6c882dea0dd1055961fba643720
pkgname = rdkit
diff --git a/PKGBUILD b/PKGBUILD
index c60957521a23..742ab7ee0578 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,19 @@
pkgname=rdkit
_pkgname=RDKit
pkgver=2018_03_2
-pkgrel=1
+pkgrel=2
pkgdesc="RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python."
arch=("i686" "x86_64" "armv7h")
url="http://rdkit.org/"
license=('New BSD License')
-depends=( 'bison' 'boost' 'boost-libs' 'cmake' 'flex' 'python' 'python-numpy' 'sqlite3' 'python-cairocffi' 'python-pillow')
-source=("https://github.com/rdkit/rdkit/archive/Release_${pkgver}.tar.gz" "http://www.inchi-trust.org/download/105/INCHI-1-SRC.zip")
-sha256sums=('29eeba93e723f0f9d61e31cf0f89ec18ba942a7f9e416dbc1a92122fce08cbed'
- '4ac311ca3a16fa75d695ec4fc711e74045c6d6c882dea0dd1055961fba643720')
+depends=( 'bison' 'boost' 'boost-libs' 'cmake' 'flex' 'python' 'python-numpy' 'sqlite3' 'python-cairocffi' 'python-pillow' 'inchi')
+source=("https://github.com/rdkit/rdkit/archive/Release_${pkgver}.tar.gz")
+sha256sums=('29eeba93e723f0f9d61e31cf0f89ec18ba942a7f9e416dbc1a92122fce08cbed')
conflicts=('rdkit-python2' 'rdkit-git')
build() {
- cd ${srcdir}
- mkdir build
- mkdir -p rdkit-Release_${pkgver}/External/INCHI-API/src
- cp -a INCHI-1-SRC/* rdkit-Release_${pkgver}/External/INCHI-API/src
- cd build
- cmake ../${pkgname}-Release_${pkgver} \
+ cd ${srcdir}/${pkgname}-Release_${pkgver}
+ cmake . \
-DCMAKE_BUILD_TYPE=Release \
-DRDK_INSTALL_INTREE=0 \
-DCMAKE_INSTALL_PREFIX=/usr \