summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsamoturk2015-09-28 13:09:09 +0200
committersamoturk2015-09-28 13:09:09 +0200
commit7cb25fa59f0c00989e756b9c708179158de1a679 (patch)
treef4afeb780f6ac9be878ac8a975707c336f4339e6
downloadaur-7cb25fa59f0c00989e756b9c708179158de1a679.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD41
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e26075108fe4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = rdkit-git
+ pkgdesc = RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python.
+ pkgver = 20150928
+ pkgrel = 1
+ url = http://rdkit.org/
+ arch = i686
+ arch = x86_64
+ license = New BSD License
+ makedepends = git
+ depends = bison
+ depends = boost
+ depends = boost-libs
+ depends = cmake
+ depends = flex
+ depends = python
+ depends = sqlite3
+ depends = python-numpy
+ provides = rdkit
+
+pkgname = rdkit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..79bbb35ee3a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Samo Turk <samo.turk@gmail.com>
+pkgname=rdkit-git
+_pkgname=RDKit
+gitname=rdkit
+pkgver=20150928
+pkgrel=1
+pkgdesc="RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python."
+arch=("i686" "x86_64")
+url="http://rdkit.org/"
+license=('New BSD License')
+depends=( 'bison' 'boost' 'boost-libs' 'cmake' 'flex' 'python' 'sqlite3' 'python-numpy')
+makedepends=('git')
+source=()
+md5sums=()
+provides=('rdkit')
+_gitroot="https://github.com/rdkit/rdkit.git"
+_gitname="rdkit"
+_gitbranch="master"
+
+build() {
+ cd ${srcdir}
+ mkdir build
+ cd build
+ git clone $_gitroot
+ cmake ../build/${gitname} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DRDK_INSTALL_INTREE=0 \
+ -DRDK_BUILD_THREADSAFE_SSS=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DPYTHON_LIBRARY=/usr/lib/python3.4/config-3.4m/libpython3.4m.so \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.4m/ \
+ -DPYTHON_EXECUTABLE=/usr/bin/python
+ make
+}
+
+
+package() {
+ echo "Making package.."
+ cd ${srcdir}/build
+ make DESTDIR=${pkgdir} install
+}