summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Minges2020-04-15 10:09:41 +0200
committerAlexander Minges2020-04-15 10:09:41 +0200
commit301efc689ae26b8dc50141690b5939a0fe94afac (patch)
tree2dd83fe6a414f585890f8c3cfe06bb4957d54f7c
parent4828954290764bb74aa506e9d5ccd5e65e5b3428 (diff)
downloadaur-rdkit-python2.tar.gz
Release 2018_09_3 is the last to support Python2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bfbbc240564..8fc722b0a92c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rdkit-python2
pkgdesc = RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python.
- pkgver = 2019_03_4
+ pkgver = 2018_09_3
pkgrel = 1
url = http://rdkit.org/
arch = i686
@@ -21,8 +21,8 @@ pkgbase = rdkit-python2
provides = rdkit
conflicts = rdkit
conflicts = rdkit-git
- source = https://github.com/rdkit/rdkit/archive/Release_2019_03_4.tar.gz
- sha256sums = 33c8eb5b3162296662ec06f8dd58e11fc21fa2ebcb13b456fcb3c4f3a39a357c
+ source = https://github.com/rdkit/rdkit/archive/Release_2018_09_3.tar.gz
+ sha256sums = 3be20bade43657c0d74617ab99ca30f872eaaedc314a87f690ac38e5ef590224
pkgname = rdkit-python2
diff --git a/PKGBUILD b/PKGBUILD
index 197e6853e33c..df68c34e540c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Samo Turk <samo.turk@gmail.com>
pkgname=rdkit-python2
_pkgname=RDKit
-pkgver=2019_03_4
+pkgver=2018_09_3
pkgrel=1
pkgdesc="RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python."
arch=("i686" "x86_64" "armv7h")
@@ -10,24 +10,24 @@ url="http://rdkit.org/"
license=('New BSD License')
depends=( 'bison' 'boost' 'boost-libs' 'cmake' 'flex' 'python2' 'python2-numpy' 'sqlite3' 'python2-cairo' 'python2-pillow' 'eigen3')
source=("https://github.com/rdkit/rdkit/archive/Release_${pkgver}.tar.gz")
-sha256sums=('33c8eb5b3162296662ec06f8dd58e11fc21fa2ebcb13b456fcb3c4f3a39a357c')
+sha256sums=('3be20bade43657c0d74617ab99ca30f872eaaedc314a87f690ac38e5ef590224')
provides=('rdkit')
conflicts=('rdkit' 'rdkit-git')
build() {
cd ${srcdir}/rdkit-Release_${pkgver}
- cmake . \
+ cmake . \
-DCMAKE_BUILD_TYPE=Release \
-DRDK_INSTALL_INTREE=0 \
-DCMAKE_INSTALL_PREFIX=/usr \
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7/ \
- -DPYTHON_EXECUTABLE=/usr/bin/python2
-# -DRDK_BUILD_INCHI_SUPPORT=ON
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DRDK_BUILD_INCHI_SUPPORT=OFF
make
}
package() {
- cd ${srcdir}/${pkgname}-Release_${pkgver}
+ cd ${srcdir}/rdkit-Release_${pkgver}
make DESTDIR=${pkgdir} install
}