summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Minges2019-09-13 13:44:03 +0200
committerAlexander Minges2019-09-13 13:44:03 +0200
commit499a395fbe80c96be93f5232156dc7d20b9986b4 (patch)
treed9144ee34d1e81ba1a29fb130636083456d10955
parent713f26ef6e39f371b3d2761847231e99be138037 (diff)
downloadaur-499a395fbe80c96be93f5232156dc7d20b9986b4.tar.gz
version bump; depend on python2-cairo instead of python2-cairocffi
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d433967d326..16313281fd87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Mon Jan 21 11:30:26 UTC 2019
pkgbase = rdkit-python2
pkgdesc = RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python.
- pkgver = 2018_09_1
+ pkgver = 2019_03_1
pkgrel = 1
url = http://rdkit.org/
arch = i686
@@ -17,15 +15,14 @@ pkgbase = rdkit-python2
depends = python2
depends = python2-numpy
depends = sqlite3
- depends = python2-cairocffi
+ depends = python2-cairo
depends = python2-pillow
- depends = inchi
depends = eigen3
provides = rdkit
conflicts = rdkit
conflicts = rdkit-git
- source = https://github.com/rdkit/rdkit/archive/Release_2018_09_1.tar.gz
- sha256sums = 61c14652a05a6f6b216ff099381c4dd32048861ba9d96f75a017084e81848baa
+ source = https://github.com/rdkit/rdkit/archive/Release_2019_03_1.tar.gz
+ sha256sums = 41d0d9b82daaca8662b269096361577537fe098176c7da9cf5301c42d2f2068e
pkgname = rdkit-python2
diff --git a/PKGBUILD b/PKGBUILD
index b9c73288fb57..8099eae3de76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Contributor: Samo Turk <samo.turk@gmail.com>
pkgname=rdkit-python2
_pkgname=RDKit
-pkgver=2018_09_1
+pkgver=2019_03_1
pkgrel=1
pkgdesc="RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python."
arch=("i686" "x86_64" "armv7h")
url="http://rdkit.org/"
license=('New BSD License')
-depends=( 'bison' 'boost' 'boost-libs' 'cmake' 'flex' 'python2' 'python2-numpy' 'sqlite3' 'python2-cairocffi' 'python2-pillow' 'inchi' 'eigen3')
+depends=( 'bison' 'boost' 'boost-libs' 'cmake' 'flex' 'python2' 'python2-numpy' 'sqlite3' 'python2-cairo' 'python2-pillow' 'eigen3')
source=("https://github.com/rdkit/rdkit/archive/Release_${pkgver}.tar.gz")
-sha256sums=('61c14652a05a6f6b216ff099381c4dd32048861ba9d96f75a017084e81848baa')
+sha256sums=('41d0d9b82daaca8662b269096361577537fe098176c7da9cf5301c42d2f2068e')
provides=('rdkit')
conflicts=('rdkit' 'rdkit-git')
@@ -22,8 +22,8 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7/ \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DRDK_BUILD_INCHI_SUPPORT=ON
+ -DPYTHON_EXECUTABLE=/usr/bin/python2
+# -DRDK_BUILD_INCHI_SUPPORT=ON
make
}