summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Minges2017-06-15 22:29:10 +0200
committerAlexander Minges2017-06-15 22:29:10 +0200
commitf872d099f1fa7109f621278109cb323b7a2e9fde (patch)
treeb6174426bc269af219328d14b1a217c7174cd7fd
downloadaur-f872d099f1fa7109f621278109cb323b7a2e9fde.tar.gz
initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD37
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f5ad5c6c234
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Thu Jun 15 20:29:00 UTC 2017
+pkgbase = rdkit-python2
+ pkgdesc = RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python.
+ pkgver = 2017_03_2
+ pkgrel = 1
+ url = http://rdkit.org/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = New BSD License
+ depends = bison
+ depends = boost
+ depends = boost-libs
+ depends = cmake
+ depends = flex
+ depends = python2
+ depends = python2-numpy
+ depends = sqlite3
+ depends = python2-cairocffi
+ depends = python2-pillow
+ provides = rdkit
+ conflicts = rdkit,rdkit-git
+ source = https://github.com/rdkit/rdkit/archive/Release_2017_03_2.tar.gz
+ source = http://www.inchi-trust.org/download/104/INCHI-1-API.zip
+ md5sums = c835bbd363154afcd2801881b891c19b
+ md5sums = 8447bf108af12fe66eecba41bbc89918
+
+pkgname = rdkit-python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..641a295b7ba4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Alexander Minges <alexander.minges@gmail.com>
+# Contributor: Samo Turk <samo.turk@gmail.com>
+pkgname=rdkit-python2
+_pkgname=RDKit
+pkgver=2017_03_2
+pkgrel=1
+pkgdesc="RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python."
+arch=("i686" "x86_64" "armv7h")
+url="http://rdkit.org/"
+license=('New BSD License')
+depends=( 'bison' 'boost' 'boost-libs' 'cmake' 'flex' 'python2' 'python2-numpy' 'sqlite3' 'python2-cairocffi' 'python2-pillow')
+source=("https://github.com/rdkit/rdkit/archive/Release_${pkgver}.tar.gz" "http://www.inchi-trust.org/download/104/INCHI-1-API.zip")
+md5sums=('c835bbd363154afcd2801881b891c19b'
+ '8447bf108af12fe66eecba41bbc89918')
+provides=('rdkit')
+conflicts=('rdkit','rdkit-git')
+
+build() {
+ cd ${srcdir}
+ mkdir build
+ cp INCHI-1-API/INCHI_API/inchi_dll/* rdkit-Release_${pkgver}/External/INCHI-API/
+ cd build
+ cmake ../rdkit-Release_${pkgver} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DRDK_INSTALL_INTREE=0 \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.6m.so \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7/ \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DRDK_BUILD_INCHI_SUPPORT=ON
+ make
+}
+
+package() {
+ cd ${srcdir}/build
+ make DESTDIR=${pkgdir} install
+}