summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2016-11-27 11:58:12 +0200
committerMantas Mikulėnas2016-11-27 11:58:12 +0200
commited628e2a0022dff8a99720459d336bffbca6fb5b (patch)
treeea2a09aa1664dc906eb504221737be7360a81b0e
downloadaur-ed628e2a0022dff8a99720459d336bffbca6fb5b.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0e87bb47dd8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Sun Nov 27 09:58:04 UTC 2016
+pkgbase = rdpsign
+ pkgdesc = Remote Desktop Protocol (.rdp) file signing
+ pkgver = r7.g89cd08646ea5
+ pkgrel = 1
+ url = https://github.com/nfedera/rdpsign
+ arch = any
+ license = Apache
+ depends = openssl
+ source = git+https://github.com/nfedera/rdpsign
+ sha256sums = SKIP
+
+pkgname = rdpsign
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98c268fbe49e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Mantas Mikulėnas <grawity@gmail.com>
+pkgname=rdpsign
+pkgver=r7.g89cd08646ea5
+pkgrel=1
+pkgdesc="Remote Desktop Protocol (.rdp) file signing"
+arch=(any)
+url=https://github.com/nfedera/rdpsign
+license=(Apache)
+depends=(openssl)
+source=("git+https://github.com/nfedera/rdpsign")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ echo r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd $pkgname
+ install -D -m 0755 rdpsign.py "$pkgdir"/usr/bin/rdpsign
+}