summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2020-10-19 08:57:28 -1000
committerGaetan Bisson2020-10-19 08:57:28 -1000
commitf47a4ee83d09d98f1ee486bb5f6f9f21ca8d4e28 (patch)
tree655782a5b5307c76e5950305e0c6e6b1709991b3
downloadaur-f47a4ee83d09d98f1ee486bb5f6f9f21ca8d4e28.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d120780e4748
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = rdrview-git
+ pkgdesc = Command line tool to extract the main content from a webpage
+ pkgver = 20201016.00207dc
+ pkgrel = 1
+ url = https://github.com/eafer/rdrview
+ arch = x86_64
+ license = custom
+ makedepends = git
+ depends = curl
+ depends = libxml2
+ depends = libseccomp
+ provides = rdrview
+ conflicts = rdrview
+ source = git+https://github.com/eafer/rdrview.git
+ source = https://github.com/eafer/rdrview/commit/ff9b0619235db1f1ab12f7d164affd9bc957a891.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = rdrview-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f03c267a854f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=rdrview-git
+_pkgname=rdrview
+pkgver=20201016.00207dc
+pkgrel=1
+pkgdesc='Command line tool to extract the main content from a webpage'
+url='https://github.com/eafer/rdrview'
+license=('custom')
+arch=('x86_64')
+makedepends=('git')
+depends=('curl' 'libxml2' 'libseccomp')
+source=('git+https://github.com/eafer/rdrview.git'
+ 'https://github.com/eafer/rdrview/commit/ff9b0619235db1f1ab12f7d164affd9bc957a891.patch')
+sha256sums=('SKIP'
+ 'SKIP')
+
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ patch -p1 -i ../ff9b0619235db1f1ab12f7d164affd9bc957a891.patch
+
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make PREFIX="${pkgdir}" install
+}