summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoel Maersk2016-05-09 15:55:40 +0300
committerNoel Maersk2016-05-09 15:55:40 +0300
commit35f550f7e35ccb2a787ab6f262d9e8180a4259f3 (patch)
tree7c913e0ca16ba9bc29da330ffa90eab978b8dbb7
parent3ef5aec9ae343f39fdd25a08797cdf0054800914 (diff)
downloadaur-35f550f7e35ccb2a787ab6f262d9e8180a4259f3.tar.gz
1.1.15 released on March 2nd.
Memory leak fixed, so patch removed.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--libarchive-depr-fix.patch13
3 files changed, 11 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f3ec02ea4b0..53d59cf0442e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rdup
pkgdesc = Generates a file list suitable for making backups. Processing tool included.
- pkgver = 1.1.14
- pkgrel = 3
+ pkgver = 1.1.15
+ pkgrel = 1
url = http://archive.miek.nl/projects/rdup
arch = i686
arch = x86_64
@@ -10,10 +10,8 @@ pkgbase = rdup
depends = pcre
depends = libarchive
depends = nettle
- source = http://archive.miek.nl/projects/rdup/rdup-1.1.14.tar.bz2
- source = libarchive-depr-fix.patch
- sha1sums = 49dc7570122bfa362f36a26a2ffa8bfe8ad55182
- sha1sums = 69cd5825f7ec196f3bf906565f373fde9275cfc8
+ source = https://github.com/miekg/rdup/archive/1.1.15.tar.gz
+ md5sums = 22636438d7cd35f73ddd0a80bf3cf42b
pkgname = rdup
diff --git a/PKGBUILD b/PKGBUILD
index 50d75b5f393d..61d43b479a1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,21 @@
-# Maintainer: Noel Maersk <veox-at-wemakethings-dot-net>
-# Contributor: Gergely Tamas <dice-at-mfa-dot-kfki-dot-hu>
+# Maintainer: Noel Maersk <veox the wemakethings toad net>
+# Contributor: Gergely Tamas <dice the mfa toad kfki toad hu>
# Contributor: Jan Spakula bender02 at archlinux dot us
pkgname=rdup
-pkgver=1.1.14
-pkgrel=3
+pkgver=1.1.15
+pkgrel=1
pkgdesc="Generates a file list suitable for making backups. Processing tool included."
url="http://archive.miek.nl/projects/rdup"
license=("GPL3")
depends=('glib2' 'pcre' 'libarchive' 'nettle')
arch=('i686' 'x86_64')
-source=(http://archive.miek.nl/projects/$pkgname/$pkgname-$pkgver.tar.bz2
- libarchive-depr-fix.patch)
-sha1sums=('49dc7570122bfa362f36a26a2ffa8bfe8ad55182'
- '69cd5825f7ec196f3bf906565f373fde9275cfc8')
+source=(https://github.com/miekg/$pkgname/archive/$pkgver.tar.gz)
+md5sums=('22636438d7cd35f73ddd0a80bf3cf42b')
build() {
cd $srcdir/$pkgname-$pkgver
- patch -p2 < "$srcdir/libarchive-depr-fix.patch"
+ autoreconf -fi
./configure --prefix=/usr --sysconfdir=/etc
make -j1
}
diff --git a/libarchive-depr-fix.patch b/libarchive-depr-fix.patch
deleted file mode 100644
index dfefd183603b..000000000000
--- a/libarchive-depr-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/rdup-1.1.14/rdup-tr.c b/rdup-1.1.14/rdup-tr.c
-index 2b7d05c..3b671fc 100644
---- a/rdup-1.1.14/rdup-tr.c
-+++ b/rdup-1.1.14/rdup-tr.c
-@@ -364,7 +364,7 @@ not_s_isreg:
-
- if (opt_output != O_RDUP) {
- archive_write_close(archive);
-- archive_write_finish(archive);
-+ archive_write_free(archive);
- }
- g_free(readbuf);
- g_free(buf);