summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitrij D. Czarkoff2015-10-16 16:04:07 +0200
committerDmitrij D. Czarkoff2015-10-16 16:04:07 +0200
commit463172a0af088b3dc332784fa0b6e2f38117c600 (patch)
treeed0eb2213a58d871143414417e09718a9a254f49
downloadaur-463172a0af088b3dc332784fa0b6e2f38117c600.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
-rw-r--r--fix_compatibility_with_glibc_2.22.diff33
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f12a8726d6f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = re
+ pkgdesc = portable library for real-time communications
+ pkgver = 0.4.13
+ pkgrel = 1
+ url = http://creytiv.com/re.html
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = openssl
+ depends = zlib
+ source = http://creytiv.com/pub/re-0.4.13.tar.gz
+ source = fix_compatibility_with_glibc_2.22.diff
+ md5sums = d5405878ca66c09d5e2e3b4e3d0c4c26
+ md5sums = 401fc777cd05a931906ab746cde6bda2
+
+pkgname = re
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..75cb4137f783
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5c07a8f7496
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Dmitrij D. Czarkoff <czarkoff@gmail.com>
+pkgname=re
+pkgver=0.4.13
+pkgrel=1
+pkgdesc="portable library for real-time communications"
+arch=('i686' 'x86_64')
+url="http://creytiv.com/re.html"
+license=('BSD')
+depends=('openssl' 'zlib')
+#changelog=ChangeLog
+source=("http://creytiv.com/pub/$pkgname-$pkgver.tar.gz"
+ "fix_compatibility_with_glibc_2.22.diff")
+md5sums=('d5405878ca66c09d5e2e3b4e3d0c4c26'
+ '401fc777cd05a931906ab746cde6bda2')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 -i "$srcdir/fix_compatibility_with_glibc_2.22.diff"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/fix_compatibility_with_glibc_2.22.diff b/fix_compatibility_with_glibc_2.22.diff
new file mode 100644
index 000000000000..eedde34ccb64
--- /dev/null
+++ b/fix_compatibility_with_glibc_2.22.diff
@@ -0,0 +1,33 @@
+diff -r 1e4e2b4aba15 src/net/posix/pif.c
+--- a/src/net/posix/pif.c Thu Oct 08 08:40:30 2015 +0000
++++ b/src/net/posix/pif.c Tue Oct 13 02:21:30 2015 +0200
+@@ -8,6 +8,7 @@
+ #include <sys/ioctl.h>
+ #include <sys/socket.h>
+ #define __USE_POSIX 1 /**< Use POSIX code */
++#define __USE_XOPEN2K 1/**< Use POSIX.1:2001 code */
+ #include <netdb.h>
+ #define __USE_MISC 1 /**< Use MISC code */
+ #include <net/if.h>
+diff -r 1e4e2b4aba15 src/tcp/tcp.c
+--- a/src/tcp/tcp.c Thu Oct 08 08:40:30 2015 +0000
++++ b/src/tcp/tcp.c Tue Oct 13 02:21:30 2015 +0200
+@@ -12,6 +12,7 @@
+ #endif
+ #if !defined(WIN32) && !defined (CYGWIN)
+ #define __USE_POSIX 1 /**< Use POSIX flag */
++#define __USE_XOPEN2K 1/**< Use POSIX.1:2001 code */
+ #define __USE_MISC 1
+ #include <netdb.h>
+ #endif
+diff -r 1e4e2b4aba15 src/udp/udp.c
+--- a/src/udp/udp.c Thu Oct 08 08:40:30 2015 +0000
++++ b/src/udp/udp.c Tue Oct 13 02:21:30 2015 +0200
+@@ -12,6 +12,7 @@
+ #endif
+ #if !defined(WIN32) && !defined (CYGWIN)
+ #define __USE_POSIX 1 /**< Use POSIX flag */
++#define __USE_XOPEN2K 1/**< Use POSIX.1:2001 code */
+ #include <netdb.h>
+ #endif
+ #include <string.h>