summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2019-01-22 21:12:19 -0500
committerAndrew Sun2019-01-22 21:12:19 -0500
commit914a25b60dbbb3d353d06d41215e3d10167828a4 (patch)
tree3da79195832afdc3f4979f70872c01b094ab2983
parente0513020c66765666396415526bf5e99bacc67ef (diff)
downloadaur-914a25b60dbbb3d353d06d41215e3d10167828a4.tar.gz
re: update to 0.6.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
-rw-r--r--re-flags.patch12
3 files changed, 35 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2ec4bfb8d34..af7f1ef25916 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = re
pkgdesc = portable library for real-time communications
- pkgver = 0.5.0
+ pkgver = 0.6.0
pkgrel = 1
url = http://creytiv.com/re.html
arch = i686
@@ -8,8 +8,10 @@ pkgbase = re
license = BSD
depends = openssl
depends = zlib
- source = http://creytiv.com/pub/re-0.5.0.tar.gz
- md5sums = 40823ef4391886fbe3ecad665180e98b
+ source = http://creytiv.com/pub/re-0.6.0.tar.gz
+ source = re-flags.patch
+ sha256sums = 0e97bcb5cc8f84d6920aa78de24c7d4bf271c5ddefbb650848e0db50afe98131
+ sha256sums = fb1c3db52d49953dbc689b105b3bf90c86ddbde44fbe2cfcf2f271c02e48d36b
pkgname = re
diff --git a/PKGBUILD b/PKGBUILD
index 9a53dfde4323..8c5320e53dfa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,31 @@
-# Maintainer: Dmitrij D. Czarkoff <czarkoff@gmail.com>
+# Maintainer: Andrew Sun <adsun701@gmail.com>
+# Contributor: Dmitrij D. Czarkoff <czarkoff@gmail.com>
+
pkgname=re
-pkgver=0.5.0
+pkgver=0.6.0
pkgrel=1
pkgdesc="portable library for real-time communications"
arch=('i686' 'x86_64')
url="http://creytiv.com/re.html"
license=('BSD')
depends=('openssl' 'zlib')
-source=("http://creytiv.com/pub/$pkgname-$pkgver.tar.gz")
-md5sums=('40823ef4391886fbe3ecad665180e98b')
+source=("http://creytiv.com/pub/${pkgname}-${pkgver}.tar.gz"
+ "re-flags.patch")
+sha256sums=('0e97bcb5cc8f84d6920aa78de24c7d4bf271c5ddefbb650848e0db50afe98131'
+ 'fb1c3db52d49953dbc689b105b3bf90c86ddbde44fbe2cfcf2f271c02e48d36b')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/re-flags.patch"
+}
build() {
- cd "$pkgname-$pkgver"
- make
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
}
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 docs/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}
diff --git a/re-flags.patch b/re-flags.patch
new file mode 100644
index 000000000000..821d3305f21c
--- /dev/null
+++ b/re-flags.patch
@@ -0,0 +1,12 @@
+diff -Naur re-0.6.0.orig/Makefile re-0.6.0/Makefile
+--- re-0.6.0.orig/Makefile 2019-01-22 21:09:25.991849231 -0500
++++ re-0.6.0/Makefile 2019-01-22 21:11:11.580636432 -0500
+@@ -65,7 +65,7 @@
+
+ $(SHARED): $(OBJS)
+ @echo " LD $@"
+- @$(LD) $(LFLAGS) $(SH_LFLAGS) $^ $(LIBS) -o $@
++ @$(LD) $(LDFLAGS) $(LFLAGS) $(SH_LFLAGS) $^ $(LIBS) -o $@
+
+
+ $(STATIC): $(OBJS)