summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitrij D. Czarkoff2016-12-03 11:42:05 +0100
committerDmitrij D. Czarkoff2016-12-03 11:44:22 +0100
commite0513020c66765666396415526bf5e99bacc67ef (patch)
treeea4ee33e6b78fd5995d3781caf81b1d62d51dc5e
parent463172a0af088b3dc332784fa0b6e2f38117c600 (diff)
downloadaur-e0513020c66765666396415526bf5e99bacc67ef.tar.gz
Update to re-0.5.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
-rw-r--r--fix_compatibility_with_glibc_2.22.diff33
3 files changed, 6 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f12a8726d6f0..d2ec4bfb8d34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = re
pkgdesc = portable library for real-time communications
- pkgver = 0.4.13
+ pkgver = 0.5.0
pkgrel = 1
url = http://creytiv.com/re.html
arch = i686
@@ -8,10 +8,8 @@ pkgbase = re
license = BSD
depends = openssl
depends = zlib
- source = http://creytiv.com/pub/re-0.4.13.tar.gz
- source = fix_compatibility_with_glibc_2.22.diff
- md5sums = d5405878ca66c09d5e2e3b4e3d0c4c26
- md5sums = 401fc777cd05a931906ab746cde6bda2
+ source = http://creytiv.com/pub/re-0.5.0.tar.gz
+ md5sums = 40823ef4391886fbe3ecad665180e98b
pkgname = re
diff --git a/PKGBUILD b/PKGBUILD
index c5c07a8f7496..9a53dfde4323 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,14 @@
# Maintainer: Dmitrij D. Czarkoff <czarkoff@gmail.com>
pkgname=re
-pkgver=0.4.13
+pkgver=0.5.0
pkgrel=1
pkgdesc="portable library for real-time communications"
arch=('i686' 'x86_64')
url="http://creytiv.com/re.html"
license=('BSD')
depends=('openssl' 'zlib')
-#changelog=ChangeLog
-source=("http://creytiv.com/pub/$pkgname-$pkgver.tar.gz"
- "fix_compatibility_with_glibc_2.22.diff")
-md5sums=('d5405878ca66c09d5e2e3b4e3d0c4c26'
- '401fc777cd05a931906ab746cde6bda2')
-
-prepare() {
- cd "$pkgname-$pkgver"
- patch -p1 -i "$srcdir/fix_compatibility_with_glibc_2.22.diff"
-}
+source=("http://creytiv.com/pub/$pkgname-$pkgver.tar.gz")
+md5sums=('40823ef4391886fbe3ecad665180e98b')
build() {
cd "$pkgname-$pkgver"
diff --git a/fix_compatibility_with_glibc_2.22.diff b/fix_compatibility_with_glibc_2.22.diff
deleted file mode 100644
index eedde34ccb64..000000000000
--- a/fix_compatibility_with_glibc_2.22.diff
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -r 1e4e2b4aba15 src/net/posix/pif.c
---- a/src/net/posix/pif.c Thu Oct 08 08:40:30 2015 +0000
-+++ b/src/net/posix/pif.c Tue Oct 13 02:21:30 2015 +0200
-@@ -8,6 +8,7 @@
- #include <sys/ioctl.h>
- #include <sys/socket.h>
- #define __USE_POSIX 1 /**< Use POSIX code */
-+#define __USE_XOPEN2K 1/**< Use POSIX.1:2001 code */
- #include <netdb.h>
- #define __USE_MISC 1 /**< Use MISC code */
- #include <net/if.h>
-diff -r 1e4e2b4aba15 src/tcp/tcp.c
---- a/src/tcp/tcp.c Thu Oct 08 08:40:30 2015 +0000
-+++ b/src/tcp/tcp.c Tue Oct 13 02:21:30 2015 +0200
-@@ -12,6 +12,7 @@
- #endif
- #if !defined(WIN32) && !defined (CYGWIN)
- #define __USE_POSIX 1 /**< Use POSIX flag */
-+#define __USE_XOPEN2K 1/**< Use POSIX.1:2001 code */
- #define __USE_MISC 1
- #include <netdb.h>
- #endif
-diff -r 1e4e2b4aba15 src/udp/udp.c
---- a/src/udp/udp.c Thu Oct 08 08:40:30 2015 +0000
-+++ b/src/udp/udp.c Tue Oct 13 02:21:30 2015 +0200
-@@ -12,6 +12,7 @@
- #endif
- #if !defined(WIN32) && !defined (CYGWIN)
- #define __USE_POSIX 1 /**< Use POSIX flag */
-+#define __USE_XOPEN2K 1/**< Use POSIX.1:2001 code */
- #include <netdb.h>
- #endif
- #include <string.h>