summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfarawayer2016-08-28 02:19:28 +0300
committerfarawayer2016-08-28 02:19:28 +0300
commit119b95a3c9c3df9cbd8a1ff99b0b892155180a1b (patch)
tree0eae3b08661f3b97c7e4a51c3af72ba53bec6902
parentb3e498503db34af857de50872d5435bb2f396217 (diff)
downloadaur-119b95a3c9c3df9cbd8a1ff99b0b892155180a1b.tar.gz
add desktop
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD17
-rw-r--r--icon.pngbin0 -> 38619 bytes
-rw-r--r--react-native-debugger.desktop9
5 files changed, 30 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e93a3abbc0cf..510e3160e87e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
pkgbase = react-native-debugger
pkgdesc = The standalone app for React Native Debugger, with React DevTools / Redux DevTools
pkgver = 0.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jhen0409/react-native-debugger
arch = x86_64
license = MIT
source = https://github.com/jhen0409/react-native-debugger/releases/download/v0.4.0/rn-debugger-linux-x64.zip
+ source = react-native-debugger.desktop
+ source = icon.png
sha512sums = 8afb18d1a0a268164e5706c936b23838bec8a009d5c62a45ed235672c369c7a6d4060f352d9fd3b0b07d0743cbb335539791b188486d666daf28b7a51b6dedbc
+ sha512sums = 146025ecc9ba34a22fba6576b74a042194bdf85357740da574a6aa7f6af657fba95a41e58e84684528c90154ade1eb461621b8a94600908aa254eebf4bf787ab
+ sha512sums = 1b6ad27debf69a041203c9583ad17d4aef71ceaa7d63d74a053d5d9c389d75e8dd5eee99ff66cbc78baf6c1fdd69a40b7ecdb44beac0c182f4c5b4b502816d3b
pkgname = react-native-debugger
diff --git a/.gitignore b/.gitignore
index 623d0e70ff3e..b20c2addb202 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,5 @@
!.gitignore
!.SRCINFO
!PKGBUILD
-
+!react-native-debugger.desktop
+!icon.png
diff --git a/PKGBUILD b/PKGBUILD
index 27f8858aa100..06842e7f7a4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _filename=rn-debugger-linux-x64.zip
pkgname=react-native-debugger
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="The standalone app for React Native Debugger, with React DevTools / Redux DevTools"
arch=('x86_64')
url='https://github.com/jhen0409/react-native-debugger'
@@ -12,18 +12,29 @@ depends=()
license=('MIT')
source=(
"$url/releases/download/v$pkgver/$_filename"
+ "$pkgname.desktop"
+ "icon.png"
)
sha512sums=(
'8afb18d1a0a268164e5706c936b23838bec8a009d5c62a45ed235672c369c7a6d4060f352d9fd3b0b07d0743cbb335539791b188486d666daf28b7a51b6dedbc'
+ '146025ecc9ba34a22fba6576b74a042194bdf85357740da574a6aa7f6af657fba95a41e58e84684528c90154ade1eb461621b8a94600908aa254eebf4bf787ab'
+ '1b6ad27debf69a041203c9583ad17d4aef71ceaa7d63d74a053d5d9c389d75e8dd5eee99ff66cbc78baf6c1fdd69a40b7ecdb44beac0c182f4c5b4b502816d3b'
)
package() {
- rm $srcdir/$_filename
install -d $pkgdir/opt/$pkgname
- cp -r $srcdir/. $pkgdir/opt/$pkgname
install -d $pkgdir/usr/bin
ln -s /opt/$pkgname/React\ Native\ Debugger $pkgdir/usr/bin/react-native-debugger
ln -s /opt/$pkgname/React\ Native\ Debugger $pkgdir/usr/bin/rn-debugger
+
+ install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -m644 $srcdir/icon.png $pkgdir/opt/$pkgname/
+
+ rm $srcdir/$_filename
+ rm $srcdir/$pkgname.desktop
+ rm $srcdir/icon.png
+
+ cp -r $srcdir/. $pkgdir/opt/$pkgname
}
diff --git a/icon.png b/icon.png
new file mode 100644
index 000000000000..f26e79f97d6f
--- /dev/null
+++ b/icon.png
Binary files differ
diff --git a/react-native-debugger.desktop b/react-native-debugger.desktop
new file mode 100644
index 000000000000..bda5847c2034
--- /dev/null
+++ b/react-native-debugger.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=0.4.0
+Name=React Native Debugger
+Comment=The standalone app for React Native Debugger, with React DevTools / Redux DevTools
+Exec=/usr/bin/react-native-debugger
+Icon=/opt/react-native-debugger/icon.png
+Terminal=false
+Categories=Development;