summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDIDIERJEAN Fabrice2017-06-13 17:15:18 +0200
committerDIDIERJEAN Fabrice2017-06-13 17:15:18 +0200
commit95815b6284641f485f28640c71a4812d7fe5c241 (patch)
tree5a060931a42cc38c8519a08b11a9ce54a3490d55
downloadaur-95815b6284641f485f28640c71a4812d7fe5c241.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD40
-rw-r--r--reactotron.desktop10
-rw-r--r--reactotron.pngbin0 -> 2546 bytes
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edae2ac362c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = reactotron
+ pkgdesc = Package archlinux for Reactotron
+ pkgver = 1.11.2
+ pkgrel = 1
+ url = https://github.com/infinitered/reactotron
+ arch = x86_64
+ license = GPL
+ makedepends = unzip
+ source = https://github.com/infinitered/reactotron/releases/download/v1.11.2/Reactotron-linux-x64.zip
+ source = reactotron.png
+ source = reactotron.desktop
+ sha256sums = 40437732b62a80dd114c7ef2d8bae16e24d54700f424866f6abb20968f6e2478
+ sha256sums = d933e27778d417a633975f22b2cdc2b6d8d922bffab916c92fc08062a7621896
+ sha256sums = 90a4434cfd00204fd6e1122caea254658c6f603289f15256a02955bfd7bec9ed
+
+pkgname = reactotron
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..107fb5f55d0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=reactotron
+pkgver=1.11.2
+pkgrel=1
+pkgdesc="Package archlinux for Reactotron"
+arch=('x86_64')
+url="https://github.com/infinitered/reactotron"
+license=('GPL')
+groups=()
+depends=()
+makedepends=("unzip")
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/infinitered/reactotron/releases/download/v$pkgver/Reactotron-linux-x64.zip"
+ "reactotron.png"
+ "reactotron.desktop")
+sha256sums=('40437732b62a80dd114c7ef2d8bae16e24d54700f424866f6abb20968f6e2478'
+ "d933e27778d417a633975f22b2cdc2b6d8d922bffab916c92fc08062a7621896"
+ "90a4434cfd00204fd6e1122caea254658c6f603289f15256a02955bfd7bec9ed")
+
+package() {
+ cd $srcdir
+ install -d $pkgdir/{opt/$pkgname,usr/bin}
+ cp -a Reactotron/* $pkgdir/opt/$pkgname
+ install -Dm644 $srcdir/reactotron.png $pkgdir/usr/share/pixmaps/$pkgname.png
+ install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ ln -s /opt/reactotron/Reactotron $pkgdir/usr/bin/$pkgname
+}
diff --git a/reactotron.desktop b/reactotron.desktop
new file mode 100644
index 000000000000..6757bb96cb59
--- /dev/null
+++ b/reactotron.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.11.2
+Type=Application
+Name=Reactotron
+Exec=/opt/reactotron/Reactotron %f
+Icon=reactotron
+Comment=Reactotron IDE
+Categories=Development;IDE;
+Terminal=false
+
diff --git a/reactotron.png b/reactotron.png
new file mode 100644
index 000000000000..e8cc841c56b1
--- /dev/null
+++ b/reactotron.png
Binary files differ